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IMPORTANT
Eddy Current Inspection

VisualPlus 3 is an eddy current inspection tool to be used in
conjunction with visual cylinder inspection. Eddy current inspection
IS NOT A SUBSTITUTE for visual inspection by a properly trained
inspector. EACH CYLINDER MUST BE VISUALLY INSPECTED BY
A PROPERLY TRAINED INSPECTOR AFTER EDDY CURRENT
INSPECTION. We recommend our OpticalPlus product to assist in
visual cylinder inspection.
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The manufacturer, importer, and the dealer cannot be held responsible for accidental damage, including personal
injury or any other damage, due to inappropriate usage of the product.

Information in the user manual is written for the current specification of the product.

The manufacturer of Visual Plus 3 system continues to provide additional functions and apply new technology to it. All
specifications may be changed without notice to individual users.

Limited Liability
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1 Visual Plus Eddy Current Inspection

IMPORTANT
VisualPlus 3 is an eddy current inspection tool to be used in conjunction with visual
cylinder inspection. Eddy current inspection IS NOT A SUBSTITUTE for visual
inspection by a properly trained inspector EACH CYLINDER MUST BE VISUALLY
INSPECTED BY A PROPERLY TRAINED INSPECTOR AFTER EDDY CURRENT
INSPECTION. We recommend our OpticalPlus product to assist in visual cylinder
inspection.

This manual is applicable to VisualPlus 3 software version 3.7.4.0 or later. 

1.1 Safety Precautions

To ensure the safe and efficient operation of your VisualPlus 3 unit, there are a number of
important safety guidelines you should always follow:

 The VisualPlus 3 unit is provided with a universal type power supply rated for 100-240V,
50-60Hz. DO NOT USE WITH ANY OTHER POWER SOURCE.

 Do not immerse or expose the unit or probe to water or other liquids.

 Use only components and attachments with your unit designed specifically for that
purpose. ANY ATTEMPT TO INSERT UNAUTHORIZED DEVICES INTO ANY OF THE
PORTS WILL VOID THE LIMITED WARRANTY.

 Do not attempt to service the unit yourself. Service should only be conducted by an
authorized service center. ANY ATTEMPT TO OPEN THE UNIT WILL VOID THE
LIMITED WARRANTY.

 Read the set-up and operating instructions before attempting to operate the unit.

 Keep this User Manual and other reference materials near the unit in a place where they
can be accessed for future reference.

 Unplug the unit from the power outlet before cleaning. Do not use liquid or aerosol
cleaners. Use a DAMP cloth and mild dish washing liquid for cleaning the unit and the
probe. A small toothbrush is recommended for cleaning the probe.

1.2 Introduction

VisualPlus 3 is an eddy current inspection device capable of recording crack indication
signals along with angular position of a probe. This capability allows VisualPlus 3 to
automatically determine the size and position of all indications and fail cylinders that do not
pass appropriate criteria.

Minimum System Requirements
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 Operating System 

 Windows 98 (*) (**)

 Windows 98 Second Edition (**)

 Windows Me (**)

 Windows 2000 (**)

 Windows XP 

 Windows Vista

 Hardware 

 Pentium II or better 

 64MB RAM 

 10MB Free drive space 

 Video card capable of supporting 1024x768 resolution 

 RS232 Serial Communications Port (9 pin) or SIIG USB-Serial Adapter (Part
#JU-CB1S12-S3). All other USB-Serial Adapters are not supported. 

(*) May require installation of Microsoft MDAC 2.5 supplied on the installation disk. Please
run mdac_typ.exe file from the installation disk after installing Visual Plus. 

(**) Windows 98/ME/2000 are not supported with Hydro Data Acquisition license. The
manual Hydro license is ok on those systems.

1.2.1 Unpacking Your VisualPlus 3

As you unpack your new VisualPlus 3 unit, please check to be sure that the following items
are included:

 VisualPlus 3 acquisition module

 One or more probes

 One or more calibration standards

 RS232 Serial Cable

 Power supply

 User Manual
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1.2.2 A Few Suggestions

Before you begin to use your VisualPlus unit, please take a few minutes to:

 Store the box and packing materials in a safe dry place for future use.

 Write down the VisualPlus 3 serial number (located on the bottom of VisualPlus 3
acquisition module, the number should be in format Axxxxxx), probe serial number
(located at the end of the probe), and calibration standard serial number (located on the
bottom of the front of the calibration standard) on your sales receipt. File your sales receipt
for future reference.

 Review instructions  on performing backups of your VisualPlus 3 database, especially if
storing records for hydro tests.

1.2.3 Getting to Know VisualPlus 3

VisualPlus 3 consists of the following components:

1. VisualPlus 3 acquisition module.

2. VisualPlus 3 probe (there may be more than one probe depending on the package
purchased).

3. Calibration Standard (there may be more than one calibration standard depending on the
package purchased).

4. RS232 Serial Cable

5. Power Supply, Regulated, 5V DC

VisualPlus 3 requires an RS232 communications port on the computer that will be used for
inspections. Most newer computers no longer have this port. If your computer does not have
such a port you have to purchase a USB-Serial Adapter. WE ONLY RECOMMEND AND
SUPPORT SIIG PART# JU-CB1S12-S3 USB TO SERIAL ADAPTER.

56
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Please note that other brands may not work at all or may work for a while and then cause
strange readings or loss of connection. There are some adapters that WILL NOT WORK for
sure with VisualPlus 3, they are: Radioshack USB-Serial adapter, IOGrear USB-Serial
adapter, SewellDirect.com SW-1301 (Prolific Chipset) USB-Serial Adapter, etc.

Please note that some customers are reporting satisfactory results with Belkin USB-Serial
adapter, although it's not officially supported it is a good second choice if SIIG adapter is not
available.

Other USB adapters that have been reported to work properly are:

 KEYSPAN, P/N: USA-16HS

1.2.4 VisualPlus 3 Probe

There are three types of VisualPlus 3 probes available: 

1. The most common type is a horizontal orientation only (accelerometer based) probe. This
type of probe will have no markings on the cable assembly 4 (see picture below). It
contains a dual axis accelerometer which allows VisualPlus 3 to measure probe angular
position by measuring force of gravity acting on each of the two axis. It is therefore
essential to observe the following rule when performing calibration and inspecting
cylinders using this type of probe:

THE PROBE MUST BE IN HORIZONTAL POSITION DURING CALIBRATION AND
INSPECTION. IT IS OK TO HAVE IT TILTED FROM HORIZONTAL PLANE BY UP TO 
± 20 DEGREES.

2. The second probe type is a universal orientation (magnetic sensor based) probe. This
type of probe will have a yellow band or one or two white plastic clips with letter M on the
cable assembly 4 (see picture below), typically close to the probe body 1. Probes with two
white clips are the latest version with improved noise immunity. If you have a probe with a
single clip or a yellow band you can send it in for a free upgrade. The probe contains a
dual axis magnetometer which allows VisualPlus 3 to measure probe angular position by
measuring earth's magnetic field acting on each of the two axis. It is therefore essential to
observe the following rules when performing calibration and inspecting cylinders using this
type of probe: 

THE PROBE COULD BE USED IN ALMOST ANY ORIENTATION (HORIZONTAL,
VERTICAL, TILTED, ETC.) AS LONG AS THE PROBE CENTER AXIS IS NOT
ALIGNED WITH EARTH'S MAGNETIC FIELD. 

PLEASE KEEP ALL LARGE FERROUS OBJECTS AND MAGNETS AT LEAST 3 FEET
(1 METER) AWAY FROM THE PROBE DURING CALIBRATION AND INSPECTION. 

KEEP THE PROBE AT LEAST 1 FOOT (30 CENTIMETERS) AWAY FROM
COMPUTERS (ESPECIALLY LAPTOPS).

MAKE SURE THAT THERE ARE NO STRONG MOVING MAGNETIC FIELDS IN THE
AREA OF INSPECTION AND CALIBRATION.

3. The third probe type is a probe driver probe. Usage of this probe type is described
separately in the Probe Driver user manual.
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VisualPlus 3 probe consists of the following components:

1. Threaded probe body

2. Eddy current sensor

3. Slip ring

4. Cable assembly

5. Alignment notch (this notch indicates the location of the eddy current sensor 2 since it is
not visible when inside of a cylinder)

6. Tension adjustment hollow set screw.

7. Tension flap

1.2.4.1 Care & Maintenance

VisualPlus 3 probe is a sensitive electronic device and requires following care:

1. It is extremely important to prevent sharp bending and kinking at the transition between
slip ring 3 and cable assembly 4. Frequent bending at this location will at some point
break a wire at the top of the slip ring which cannot be repaired without costly slip ring
replacement. If bending is prevented the probes can last for years. It is best to allow the
cable to hang freely from the probe and to watch that you are not putting pressure on the
cable during calibration and inspection.
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2. The probe body 1 is made out of acetal plastic (metal cannot be used in an eddy current
probe) which wears slightly each time it is threaded into a cylinder. Rough dirty thread on
a cylinder will wear the probe more than nice clean threads. We recommend thoroughly
cleaning cylinder threads before performing inspections.

3. As probe wears it will feel loose when it is threaded into cylinders. You may see sharp
spikes on calibration and inspection graphs. The eddy current sensor 2 is sensitive to
distance from the thread surface to the sensor, when the probe is loose the sensor is not
held firmly against the thread surface and the spikes result. To compensate for this please
use a hex key to increase tension on the flap 7 by rotating tension adjustment hollow set
screw 6 clockwise. If the probe becomes too tight, loosen the tension by rotating screw 6
counter clockwise.

1.2.4.2 Available Sizes

Probe Type Thread Size Description Tension Adjustment Screw Hex Key
Size

#1 0.75-14NPSM Scuba 5/32"

#2 0.75-16UNF Medical/Industrial
Gas

1/8"

#3 1.125-12UNF Beverage/Medical/
Industrial Gas/Fire
Extinguisher

5/32"

#4 0.875-14UNF Life Support/Fire 5/32"

#5 0.625-18UNF Paintball/Spare Air 5/64"

#6 0.75-14NGT Industrial Gas 5/32"

M18 M18 x 1.5 1/8"

M25 M25 x 2.0 5/32"

M30

25E

1.2.5 Installation

1.2.5.1 Connecting Cables

1. Connect Serial Cable (4) to VisualPlus 3 acquisition module, plug the other end of the
cable into a 9 pin RS232 serial port on the back of the computer. If computer does not
have an RS232 serial port please install a USB-Serial adapter and then plug the Serial
Cable (4) into the adapter.

2. Connect the Power Supply (5) to the VisualPlus 3 acquisition module and then plug the
Power Supply (5) into an electrical outlet (use surge protector if power surges are
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common in your area). The power supply is designed to work on 110/220v, 50/60Hz
power. You may need an outlet adapter for countries outside of USA.

3. Connect the Probe (2) to VisualPlus 3 acquisition module.

4. Press the power button on the front of VisualPlus 3 acquisition module. A red light should
visible on the left of the power button.

1.2.5.2 Installing Software

1. Please note that you should install VisualPlus 3 using a user account with Administrative
privileges.

2. If you have purchased the SIIG USB-Serial adapter please follow instructions in the USB-
Serial adapter user manual to install the drivers for it.

3. To install VisualPlus 3 software place the software CD into your CD or DVD drive. If
software installation does not start automatically please click on Start->My Computer (or
double-click My Computer or Computer icon on your desktop). Double-click on your CD or
DVD driver and double-click on Setup application. The VisualPlus 3 software installation
wizard should start.

4. On the first 'Welcome to the VisualPlus Setup Wizard' page click Next.

5. Please read the software license agreement on the next License Agreement page. If you
agree to the terms of software license agreement please click on 'I Agree' radio button
and click Next. If you do not agree please click on Cancel.

6. On the next 'Select Installation Folder' page click on 'Everyone' radio button if you would
like VisualPlus 3 software to be accessible to all users of this computer. Please do not
change the Folder unless there is a specific reason to do so. Click Next.

7. On the next 'Confirm Installation' page click Next to start installation.

8. Once installation has been completed you will be taken to the 'Installation Complete'
page. Click Close on this page.

9. The VisualPlus 3 software is now installed.

1.2.5.3 Configuring Software

1.2.5.3.1  Setting COM Port

Visual Plus software connects to Visual Plus instrument via an RS232 link. In order to
properly communicate with Visual Plus you must specify a COM port that the unit is
connected to. Typically for laptops it will be COM1, if you use a USB-Serial adapter the COM
port number is hard to predict. The best way to find out the COM port is to select 
File->Preferences from the main menu. Click on the Find button in the Visual Plus COM
Port Address group. If the unit is connected and USB-Serial adapter is installed properly the
VisualPlus 3 will find the correct COM port.
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If using Find fails to work try the following method:

1. Go to Start->Control Panel. 

2. Double-click System icon. 

3. Select Hardware tab. 

4. Click on Device Manager. 

5. Expand (double-click) the Ports (COM & LPT) item in the tree on the left side of the
window. 

6. The USB adapter or built in COM ports will be listed here. Write down available COM
port numbers. 

7. If USB Serial adapter has a yellow exclamation mark on it that means that the driver
was not installed properly. Please contact AIT for assistance with this problem. 

8. Open Visual Plus software, go to File->Preferences, enter the first COM port
number that you wrote down in 'Visual Plus COM Port Address' field. If you now
know the COM port number please enter that number. Please enter the COM port
including the 'COM' prefix with no space between COM and the number. Just the
number is not enough. Click OK. 

9. Hit F4 to enter Calibration Wizard, enter Inspector Name and Probe Type, hit Next. If
Visual Plus is still unable to connect to the unit please try steps 7-8 with the rest of
the COM port numbers that you wrote down. If you are unable to connect on any of
them please try installing software on another computer or use another USB adapter
to see if the COM port might be defective. If you are unable to connect on two
computers or you don't have another computer please contact AIT for assistance.

After the COM port has been set please click OK to save this setting. You may want to
review Preferences  section of the manual before starting inspections.36
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1.2.5.3.2  Setting Shop Information

Before proceeding with the first calibration and inspection it is recommended to set shop
details, otherwise the test report will be missing this information.

1. On the main menu select File->Shop Information.

    

2. Click on Edit.

    

3. Enter the information for this facility. The shop code is a field that can be used if there are
multiple locations that have a unique code assigned to them. If this is a hydro test facility
please enter the RIN number in the last field.

4. Click OK. The information that you entered should now be shown under Shop Info group
box. Click Close.

5. The shop information is now set.
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1.2.5.3.3  Adding Inspector Names

We also recommend that you go ahead and enter the names of inspectors that will be
performing eddy and hydro testing at this point. This allows you to select the inspector name
from drop down boxes on the main screen, calibration wizard and the PSI form. In addition,
the Hydro page of the PSI form only allows selection of an existing inspector name, you
cannot add a new inspector by typing it into Tested By field.

Please refer to Editing Inspectors  section for more information on adding inspectors.

1.3 Calibration

The Visual Plus instrument must be calibrated at the beginning of each testing session, each
time a new/different probe is to be used and whenever the base unit loses communication
with the host computer or the probe. When one of these situations occurs the software will
prompt you to run the calibration wizard before testing can begin/resume. 

Loading a file while Visual Plus is calibrated no longer invalidates the calibration. This way
you can look are previously recorded data for a cylinder before running inspection without
having to recalibrate. As soon as you start inspection, the data for the current calibration will
replace whatever was loaded from the file. 

Please note that if you are using an MPS (Magnetic Position Sensor) equipped probe
you can ignore the restriction of holding the probe horizontally. The MPS probe can
be used in almost any orientation (horizontal, vertical, etc.) as long as the probe axis
is not aligned with earth's magnetic field. Please keep all large ferrous objects and
magnets at least 3 feet (1 meter) away from the probe during calibration and
inspection. Also, please make sure that there are no strong MOVING magnetic fields
in the area.

1. BE SURE to hold the probe horizontally in right hand facing the left hand. 

2. Place flat portion of the calibration standard ring on edge of table/bench. 

3. Thread the PROBE into calibration standard ring (flat part flush on table/bench, held
with left hand) clockwise with right hand. Turn PROBE, not the standard ring! 

4. Stop when probe base is flush with end of standard and press F4. 

5. Enter the inspector's name into the Inspected By field. 

6. Enter probe type or part number into the Probe Type field. 

7. Follow instructions by turning the PROBE (hold the calibration standard fixed, do not
allow it to rotate) 2 turns counter clockwise into position B. 

27
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8. Click Next or hit enter. 

9. Follow instructions by turning the PROBE AGAIN (hold the calibration standard fixed,
do not allow it to rotate) two more turns counter clockwise. Turn the PROBE slowly
and avoid bumping it at this time. Bumping the probe may cause probe position to
show a 'step' in readings every 90 degrees. 

10. Click Next or hit enter. 

11. Turn the PROBE (not the calibration standard) clockwise into the calibration ring until
about one full thread of the probe is showing on the other side of the calibration ring
and the probe sensor indicator (bar on the graph) shows the highest measurement
for half a turn. The Next button will light up at this point. 

12. Click Next or hit enter. 

13. Turn the PROBE (not the calibration standard) counter clockwise until the probe is
pulled out of the threads and Finish button lights up. Please keep the probe speed
under the RPM limit indicated by a red line on the RPM gauge.

14. Press Finish or hit enter. 

15. Unless an error message is shown the unit is now calibrated. 

Successful calibration should look similar to this example:
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1.4 Inspection

Please note that if you are using an MPS (Magnetic Position Sensor) equipped probe
you can ignore the restriction of holding the probe horizontally. The MPS probe can
be used in almost any orientation (horizontal, vertical, etc.) as long as the probe axis
is not aligned with earth's magnetic field. Please keep all large ferrous objects and
magnets at least 3 feet (1 meter) away from the probe during calibration and
inspection. Also, please make sure that there are no strong MOVING magnetic fields
in the area.

1. Perform calibration if it hasn't been done already. If data from another inspection is
currently displayed in Visual Plus, please click on the New button on the toolbar or
select it from the main menu under File submenu (you can also press Ctrl-N ). 

2. Place a cylinder to be inspected in HORIZONTAL POSITION (a tank holder makes
inspection easier to perform, contact AIT to order). It helps if you position the cylinder
with the serial number on top, first letter of serial number at the 12 o'clock position.
Please make sure that the cylinder does not move during recording. 

3. Fill in all fields on the main screen. 
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4. Thread the PROBE into the cylinder (clockwise) until the signal on the bar graph
(right side of inspection display screen) is at maximum position. This indicates that
the probe sensor is all the way through the threaded cylinder neck. If the cylinder
does not have threads that go all the way, stop when you encounter significant
resistance turning the probe and make a note in comments section. 

5. Continue threading the PROBE into the cylinder (clockwise) until the white indicator
line on the probe lines up with the first letter of the serial number stamped on the
cylinder. All cylindrical graphs assume that inspection started with probe indicator line
aligned on the first letter of serial number, in the 12 o'clock position. You will be able
to easily compare a printout with the actual cylinder to find detected cracks. If you
were unable to thread the probe all the way into the cylinder then make a mark with a
pen on the cylinder at the location of the probe white line, this will be the zero
position for this cylinder.

6. Press F6 to start recording data. 

7. Thread the probe all the way out (counterclockwise) until the signal bar on the graph
is at maximum position, watch the probe speed indicator on the right of the
comments section to make sure that you are not exceeding the maximum rotational
speed indicated on the gauge (the maximum speed will vary depending on the
VisualPlus 3 unit model and the type of probe, Probe Driver allows for higher
speeds). 

8. Press F7 to stop recording data. 

9. Perform analysis of the data, add comments and pass or fail the inspection using
F10 to pass inspection and F11 to fail inspection. 

10. Click on the Save button on the toolbar or press Ctrl-S or F8 to save the data. 

1.5 Analysis

Visual Plus automatically attempts to detect questionable features, including cracks, defined
as indications in more than one consecutive thread in the same radial location that are larger
than 25% of the calibration standard indication height for 6351 alloy. The criteria for 6061
alloy is more than two consecutive indications exceeding 30% of the calibration standard. If
such features are found, the position and size information will be added to the “Comments”
section, and the “status of inspection” will be automatically changed to “Failed” for 6351 alloy
cylinders. For 6061 alloy cylinders, the inspection will not be automatically failed, since any
questionable features detected by VisualPlus 3 must be confirmed visually with a magnifying
optical inspection instrument, such as Optical Plus. This functionality can be enabled in the 
File->Preferences dialog box, or it can be manually executed via View->Filter->Analyze
Inspection Results. Visual Plus 3 will reject indications that are 8 degrees wider than
calibration standard for 6351 alloy and 5 degrees wider for 6061 alloy. Those indications are
usually caused by folds, valleys, corrosion, or variation in material properties and are not the
same as sustained-load cracking (SLC) of the type found in 6351 alloy cylinders. Please use
the Optical Plus visual inspection to verify that no cracks or other unacceptable features
were missed. If the data looks fine, use F10 to pass the inspection.

Please remember to save and print the results.
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1.5.1 Understanding Results

VisualPlus 3 has several different views for visualizing inspection data. Each indication is
described by it's position (in degrees) from probe location when inspection started, height (%
of calibration standard crack peak height, absolute value), and width (at half peak in
degrees). 

If the probe indicator line was aligned with the first letter of the serial number when recording
started (usually via F6 key) then the diagram below shows the locations for 0, 90, 180, and
270 degrees. Position of 360 degrees is same as 0 degrees. The position is always counted
from the probe starting position, counter clockwise.

On a graph example below two threads of an inspection trace are shown, there are two
major cracks, one at position 17 degrees counter clockwise from the starting point and
another one at position 231 degrees counter clockwise from the starting point. Each
detected peak is described using following abbreviations: Pos - position from the starting
point in degrees, Hgt - height of the peak in percent of calibration standard and the absolute
value in brackets, and Ang - half-peak width in degrees.
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The diagram below shows the locations of the cracks as viewed looking at the cylinder
crown with the probe starting location oriented in at the 12 o'clock position. A radial trace of
the inspection has been overlayed over the cylinder crown to illustrate the point further.
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The images of the cracks are shown below, image on the left is of the crack at position 17
degrees, image on the right is of the crack at position 231 degrees.
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1.5.2 What to do when a crack or questionable feature is detected

1. Clean both the probe and the cylinder thread and re-run the inspection. A stiff toothbrush
or a plastic pipe brush of appropriate diameter can be used. Please note that you don't
need to re-enter cylinder information. Pressing F6 or selecting Inspection->Start
Recording will clear existing data and start another recording. This only applies if the file
has not been loaded from disk. Changes to saved files are not allowed.

2. If cylinder passes inspection after cleaning, perform visual inspection using Optical Plus. If
no cracks or other significant defects are found you may pass the cylinder by pressing 
F10.

3. If cylinder still fails the eddy current test, using OpticalPlus thread inspection tool find the
crack/questionable features indicated by VisualPlus 3 using the angular position and
vertical position information as discussed in the previous section. If a visible crack is seen
at this or any other location fail the cylinder by pressing F11. If there is absolutely nothing
visible at the indicated locations you may pass the cylinder by pressing F10. Please be
sure that you know how to use OpticalPlus to find angular positions. 

1.5.3 Cylinders that sometimes pass and sometime fail

Please note that some tanks may have indications that are very close to the threshold set as
25% of calibration crack for 6351 alloy and 30% of calibration crack for 6061 alloy. Since
peak heights vary slightly from run to run it might be the case that for one inspection this
type of tank will pass and for another inspection it will fail. Those tanks are typically not
cracked which should always be verified with OpticalPlus visual inspection system.

If you encounter this situation it helps to clean both the cylinder thread and the probe and
re-run the test. If the probe feels loose, please adjust the tension using a hollow set screw
on the side of the probe. A truly cracked cylinder will always fail regardless of any cleaning.
On the other had a cylinder that failed because of dirt and residue on the threads should
pass this test. Please note that you don't need to re-enter cylinder information to re-run the
test. Pressing F6 or selecting Inspection->Start Recording will clear existing data and start
another recording. This only applies if the file has not been loaded from disk. Changes to
saved files are not allowed.

1.5.4 Alloy type for Luxfer cylinders manufactured between 1987 and 1989

VisualPlus 3 determines the cylinder alloy based on the Manufacturer and Manufacturing
Date fields. Luxfer made a gradual transition from 6351 to 6061 alloy between 1987 and
1989. Starting from VisualPlus 3 version 3.7.4.0 the software will recognize that additional
information is needed for a cylinder manufactured in this period. A window will come us
asking to enter the cylinder model number: 
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Please select the cylinder model number to continue. If the cylinder model does not appear
on the list please select Other. Based on the model number VisualPlus 3 will determine the
correct alloy and apply appropriate crack detection settings. Please note that 6061 cylinders
will not be failed automatically as any questionable feature must be visually verified before
failing the cylinder.

The following Luxfer technical bulletin may be of use in determining the alloy type:

November 12, 2003 

Dates when Luxfer changed its aluminum alloy from 6351
to 6061

Between 1987 and 1988, Luxfer Gas Cylinders discontinued use of 6351 aluminum alloy and
began using a proprietary version of 6061 aluminum alloy for all its aluminum cylinder
models manufactured in the United States. Listed below are the dates by model number when
the transitions to the new alloy occurred. Any current Luxfer models that do not appear on
this list were never made from 6351 alloy in the first place and have always been made from
Luxfer's proprietary 6061 alloy. 

SCUBA Change Date 
CO2 Change Date 

C1.2, C1.5 1-89

S30, S63 5-88 C2 11-88 

S40 6-88 C10 8-88
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S50, S92 4-88 C5 6-88

S72, S100 8-87 C15 11-87

S80 1-88 C20, C35 4-88

S808 5-87 C50 2-88

SCBA Change Date MEDICAL Change Date 

L7, L8, L13 9-87 M9 1-88

L13 5-88 MD15, ME24 12-87 

L15 1-89

INDUSTRIAL
GAS 

Change Date 

N22, N150 5-88

N33 11-88 

L26 2-88 N60, N122 12-87

L45 11-87 N88 12-88

1.6 Editing Customers, Inspectors, etc.

VisualPlus 3 software allows various records such as customers, inspectors, and selection
box values to be added, edited, or deleted. This information is stored in the VisualPlus 3
database. When record is deleted it is not physically removed from the database, it is
flagged as deleted so that reports depending on that record remain accessible.

1.6.1 Editing Inspectors

To add, edit or delete inspectors select Edit->Inspectors from the main menu. After all
changes have been completed click on Close button in the right upper corner to close the
Inspector Editor window.
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If the PSI Inspector Number is entered for the inspector that is currently processing cylinders
and the If PSI number is entered, automatically display PSI form option is checked in
the Preferences dialog box , the PSI form will be automatically shown when the inspection
is either passed or failed.

1.6.1.1 Adding a new inspector

To add a new inspector click on Add New button in the Inspector Editor window.

Enter the inspector First and Last name into the Name field. Enter the PSI inspector number
into the following field if the inspector has a PSI number. Click Add New to add this
inspector. Please note that the inspector name cannot be changed after addition. Double
check the inspector name accuracy before clicking Add New. If you still make a mistake you
will have to delete the inspector and add a new record.   

1.6.1.2 Editing inspector information

To change the PSI Inspector Number for a particular inspector, enter the new number in the
field to the right of the inspector name. Click Update button in the same row as the inspector
that you are editing. Please note that you can only change the PSI Inspector Number one
inspector at a time. If the number has been changed for multiple inspectors the only number
that will be stored is the number in the row where Update is clicked. All other numbers will
revert back to their original values.

1.6.1.3 Deleting inspector

To delete an inspector click Delete button in the same row as the inspector that you are
deleting. A dialog box will ask to confirm that you want to delete an inspector. Click Yes to
confirm deletion. The inspector name that was deleted will no longer show up in the
'Inspected By' boxes and the Inspector Editor but it will still show on the inspection list and
the hydro test report for inspections performed by that inspector.

1.6.2 Editing Customers

To add, edit or delete customers select Edit->Customers from the main menu. After all
changes have been completed click on Close button in the right upper corner to close the
Customer Editor window. Customer information is stored in the database and is used to
automatically populate the address and phone number fields on the PSI form. It may also be
used in the future to generate mailing labels for customer that are due for an inspection.
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1.6.2.1 Adding a new customer

To add a new customer click on Add New button in the Customer Editor window.

Enter customer information information into the fields provided. The Certification # field is
optional and can be used for tracking additional customer information. Click Add New to add
this customer. Please note that the customer name cannot be changed after addition.
Double check the customer name accuracy before clicking Add New. If you still make a
mistake you will have to delete the customer and add a new record.   

1.6.2.2 Editing customer information

To change information for a particular customer, enter the new information into fields to the
right of the customer name. Click Update button in the same row as the customer that you
are editing. The length of each row is fairly long so it may be necessary to either make the
Customer Editor window larger or use the scroll bar on the bottom of the window to scroll to
the right in order to reveal the Update button.  If information has been changed for multiple
customers the only information that will be stored is the information in the row where Update
is clicked. All other information will revert back to their original values.



Visual Plus Manual30

(c) 2006-08, Saryna Technologies LLC/Advanced Inspection Technology

1.6.2.3 Deleting customer

To delete a customer click Delete button in the same row as the customer that you are
deleting. The length of each row is fairly long so it may be necessary to either make the
Customer Editor window larger or use the scroll bar on the bottom of the window to scroll to
the right in order to reveal the Delete button. A dialog box will ask to confirm that you want
to delete a customer. Click Yes to confirm deletion. The customer name that was deleted
will no longer show up in the 'Customer' boxes and the Customer Editor but it will still show
on the inspection list and the hydro test report for inspections performed for that customer.

1.6.3 Editing Selection (drop-down) Box Values

VisualPlus 3 software allows editing of values that show up in drop-down boxes throughout
the program. Please note that some items such as pre-defined manufacturer names cannot
be deleted. To add, edit or delete drop-down box values select Edit->Selection Box
Values from the main menu. After all changes have been completed click on OK button at
the bottom to close the window.

 The name of the drop-down box for which the entries will be edited is first selected by
clicking on one of the tabs at the top of the window.

 To add a new entry click on Add New button. An edit box will appear in Additional Values
group with value 'New Value'. Type the name that you want over the 'New Value' text and
hit Enter key to save changes.

 To modify an existing entry click on the entry that you would like to modify and then click
on Modify Selected. The old value will be highlighted in an edit box. Modify this value to
the desired text and hit Enter key to save changes.
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 To delete an existing entry click on the entry that you would like to delete and then click
on Delete Selected. Please note that you can select multiple items to be deleted using
normal Windows multiple selection commands.

Please note that if you have purchased a Hydro module license you can use the 
Specification definition dialog box in Hydro menu instead of using the Specification page
of this property sheet. The hydro version of Specification definition dialog box allows entry
of additional information such as calculation of target pressure.

1.6.4 Editing Shop Information

VisualPlus 3 software allows entry of facility information for more than one location. This is
to accommodate situations where there are multiple locations connected to a central server.
Although the information can be entered for multiple location, only one can be selected as
current location. The information for this location will appear in files generated at this
computer. To edit or set the current shop information select File-Shop Information. The
current shop information that will be used on all reports generated at this computer is shown
in the Shop Info group box. When all editing has been completed and the desired shop
information is shown in Shop Info group box click the Close button.

1.6.4.1 Adding a new location

To add a new location click on the Add New button. Enter the information into the dialog box
and click OK. The shop code is a field that can be used if there are multiple locations that
have a unique code assigned to them. If this is a hydro test facility please enter the RIN
number in the last field.
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1.6.4.2 Editing existing location

To edit an existing shop please select it using the drop down box and then click on the Edit
button. Update the desired fields. The shop code is a field that can be used if there are
multiple locations that have a unique code assigned to them. If this is a hydro test facility
please enter the RIN number in the last field. Click OK when all changes have been made.

1.6.4.3 Deleting location

To delete an existing shop please select it using the drop down box and then click on the 
Delete button. Click Yes on the following dialog box after verifying that the correct shop is
being deleted. Click No if you want to cancel deletion.

Please note that it is possible to add password protection to the delete button. Please see 
page  for more info.

1.7 Viewing, Searching, and Printing Records

VisualPlus 3 software keeps track of inspections in a database that can be easily searched
to find any records of interest. 

1.7.1 Working with inspection list

The inspection list can be opened by selecting File->Open From Database from the main
menu. It can also be activated by pressing Alt-O keys or clicking on the following icon in the
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main toolbar: 

The inspection lists consists of rows representing each eddy current and/or hydro test. The
columns can be added, removed, or resized. To resize a column left mouse click and hold
on the vertical line separating the two column headers. Drag the mouse while keeping the
left mouse button down to resize. Release the mouse key once the desired column width
has been achieved. You can also double-click on the same line to resize the column to fit
data and column header perfectly. The total number of displayed/filtered records is shown
on the left side and just above the inspection list table.

To view the actual data file for a record of interest either double click on that row or select
the record with the mouse and click on the Open Record button on the toolbar:

To scroll through records either use the right scroll bar or use Up/Down arrow keys or Page
Up and Page Down. 

To quickly narrow down the list of inspections to a pre-set date range click on any of the
following icons in the inspection list toolbar:

1.7.2 Searching records

To search for records of interest select Database->Search from the main menu. This
function can also be activated by pressing Alt-S keys or clicking on the following icon in the
main toolbar or in the inspection list window: 
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The inspection records query window allows you to filter records displayed in the inspection
list to a specific subset. The cylinder serial number and the customer tracking number fields
accept wildcards. That means that you can search for records that match a certain pattern.
For example, to look for cylinders that passed inspection with serial numbers that start with 
P you can enter P% into the Serial Number field and change the Inspection Result field to
Passed.

Click OK after changing fields of interest and the list of inspections will be updated to reflect
chosen settings. You can see the filter setting above the table and to the right of the number
of inspections count.
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1.7.3 Defining columns

To change the number or the order of columns in the inspection list click on the following
icon in the inspection list window toolbar: 

The available columns that can be added to the inspection list table are shown on the left
side of the screen. The columns that are already in the table are on the right.

To add an available column to the table, select the desired column name on the left and
click Add Column or just double-click on the column name.

To remove a column from the table, select the desired column name on the right and click 
Remove Column or just double-click on the column name.

To change the order of columns, select the desired column name on the right and click 
Move Up or Move Down to change it's position.

Click OK after altering the columns and the inspection list will be shown with the selected
columns as ordered on the right side of the screen.

1.7.4 Printing results

To print records displayed in the inspection list click on the following icon in the inspection
list window toolbar: 
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In the printer selection dialog box select the printer and click OK to print. 

If you would like to shrink down the inspection list width, you can change the Scale
Inspection List Output setting in File->Preferences->Printing tab. Please see the
following section  for more information.

1.7.5 Saving and loading reports

The selected columns and filter settings can be saved and loaded by selecting following
icons in the inspection list window toolbar: 

This feature is useful when you need to print out reports for specific customers with specific
columns. You can then setup the columns and the filter to that customer and save the
report. Whenever you open this report in the future the inspection list will be adjusted to
those settings.

Important! The report file does not contain any actual records. It only contains the
formatting information. 

1.7.6 Exporting data

The data displayed in the inspection list table can be exported to MS Excel by selecting the
following icon in the inspection list window toolbar: 

Please note that MS Excel software must be installed on your system if you are using this
functionality.

The data can also be saved into a text file in CSV (comma separated) format. Click on the
following icon in the inspection list window toolbar:

Select the desired file name and location and click Save.

1.8 Preferences

The following sections describe preferences that can be set for VisualPlus 3
software. 

1.8.1 General

The General page of the Preferences property sheet is used to set VisualPlus/VisualDepth
COM port addresses as well as other generic settings.
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 Visual Plus COM Port Address - use the drop down menu to select the COM port to
which VisualPlus 3 acquisition module is connected. Click Find button to perform
automatic search for VisualPlus 3 COM port.

 Visual Depth COM Port Address - use the drop down menu to select the COM port to
which Visual Depth acquisition module is connected. If you do not have Visual Depth pit
depth measurement system this value does not matter.

 If PSI number is entered, automatically display PSI form after passing or failing
inspection - if this item is checked then whenever the eddy current inspection is passed
or failed (F10/F11 keys) if the inspector has a PSI number assigned to him/her then a PSI
form will be shown automatically. The PSI form can always be opened by pressing F3 key.

 Perform automatic analysis at the end of recording - this item should normally be
checked. If checked, VisualPlus 3 software will perform analysis of recorded data after
Stop Recoding button (F7 key) is pressed and the results of analysis are displayed in the
comments window below the graph. If software determines that inspection fails then the
Inspection Result will be set to Fail automatically.

 Use VIP Detailed Cylinder Inspection Form instead of PSI form - if checked, an
alternative visual inspection form will be used when pressing F3 or selecting 'Inspection-
>Fill Out Inspection Form' from the main menu. This item is normally not checked and the
PSI for is used.

 Prefill Customer/Serial#/Manufacturer field with 'NOT ENTERED' text on New
Document - if checked, then customer, serial#, and Manufacturer fields will be set to NOT
ENTERED whenever New Document is selected (F5 key or File->New). This can be used
if inspections are never saved unless they fail. In this scenario the inspections are done
until a tank fails, in this case all of the information gets entered and tank is inspected
again. This option is normally not checked. WARNING! WE DO NOT RECOMMEND
ENABLING THIS OPTION. UNLESS MANUFACTURER AND ORIGINAL
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MANUFACTURING DATE ARE ENTERED CORRECTLY THE VISUAL PLUS
SOFTWARE CANNOT DETERMINE WHICH ALLOY WAS USED TO MANUFACTURE A
CYLINDER.

 Make DOT Spec/Exemption field mandatory - if checked, the DOT Spec must be
entered on the main screen before starting an inspection. If this item is not checked then
inspection can start with that field blank. This is mainly used for hydro test facilities that
need to keep track of this data.

1.8.2 Data Management

The Data Management page of the Preferences property sheet is used to set parameters
related to storage of files on disk.

 The Automatically save files in this directory edit box specifies the location where
VisualPlus files will be stored by default. This means that when you press F8 or Save As
this directory will be show in the Save As box. If Store files for each customer in a
separate directory is checked then a subdirectory with a customer's name will be created
under this directory and all files for that particular customer will be stored in this
subdirectory.

 If Add -Failed to file name of a cylinder that failed an inspection is checked then -
Failed will be ended to the end of the file name for all files where the inspection was failed.

 The Format file names as CustomerName-SerialNumber-Date option changes the
default file name for each inspection to be in the following format: CustomerName-
SerialNumber-Date. For example: AIT-P123456-04-30-2004.vis, AIT-P123456-04-30-
2004-Failed.vis, etc.
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1.8.3 Printing

The Printing page of the Preferences property sheet is used to set parameters related to
printing of inspection results and reports.

 When Print file to default printer when saving file for the first time is checked then
whenever an inspection is performed and it is saved via F8 key the inspection will be
printed on the default printer. This option is very handy if your company policy is to print a
hardcopy of every inspection. The printing will only happen if the file was just created and
it is being saved for the first time, it will not print when re-saving an existing file.

 Do not use dark background on PSI form section headings to conserve printer ink/
toner will use white backgrounds on the PSI form section titles if checked.

 Print shop info (name, address,etc.) on the PSI form will add a Shop Info section to the
PSI form.

 Scale Inspection List output (%) option sets the scaling factor for printing the inspection
list and the hydro test report log. If the inspection report or the hydro test log has too many
columns you can set this value to a lower number (no less than 50%) to make the results
smaller so that they will fit on a single page.

 Print Province/Postal Code instead of State/Zip option allows customers in Canada to
have correct wording in address printouts on the PSI and inspection report forms. Check
this option if you are in Canada, leave unchecked for US.

 Print graph line thickness (pixels) - changes graph thickness to the specified value
when printing, normally it should be left at default value but if output on your printer is too
thin or too thick you can adjust it with this value.

 Print graph font size (pixels) - changes graph annotations font size to the specified
value when printing, normally it should be left at default value but if output on your printer
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is too small or large you can adjust it with this value.

1.8.4 Defaults

The Defaults page of the Preferences property sheet is used to set default values for drop
down boxes such as those on the PSI form. 

 Working Pressure Units - default units that will show up on the general page of the PSI
form. Set this field to the pressure units of cylinders that you inspect most often. Please
make sure that you select New (F5) command after changing this option for the changes
to take effect. They will not apply fully unless New is selected.

1.8.5 Hydro

The Hydro page of the Preferences property sheet is used to set parameters related to
hydro test equipment and testing. This tab is only visible if you have purchased and entered
a correct license key for the hydro acquisition module (single jacket or multiple jackets).
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 Pressure Gauge field specifies the COM port for the digital pressure gauge used in the
hydro acquisition system.

 Jacket/Scale # field - specifies the COM port for a scale assigned for a particular jacket
and whether that jacket is active. If a particular jacket is damaged or non-functional it can
be temporarily disabled from acquisition using the checkbox. Depending on the number of
licensed jacket more than a single Jacket/Scale # files may be enabled.

 Extended Permanent Expansion Measurement Period (seconds) - length of the
Extended Permanent Expansion Measurement Period in seconds, see below for more
details.

 Enable Extended Permanent Expansion Measurement Mode by Default - for smaller
cylinders the default amount of time to measure the permanent expansion may be too low,
causing good cylinders to be failed for permanent expansion that would pass given
additional 10 - 20 seconds to contract to original volume. If this option is enabled then if
any jacket has a cylinder that will fail the inspection at the end of the permanent expansion
measurement cycle then an extended permanent expansion measurement cycle is
entered which allows more time for smaller cylinders to contract to original size. The length
of this cycle is defined by the Extended Permanent Expansion Measurement Period
(seconds) field. 

 Disable REE field - check if this facility does not process any cylinders that require REE
to be used. This is used to reduce possibility of entering a value into REE field by mistake
and failing a cylinder.

 Use regulations for this country (determines specified test pressure, etc.) - please
specify which countries regulations should apply to the hydro module. This changes some
defaults and calculations, for example the default specified (target) test pressure is 5/3 for
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USA and Canada for pre-1993 cylinders, the default for 1993 and later cylinder in Canada
is 3/2 of the working pressure. Please make sure that you select New (F5) command after
changing this option for the changes to take effect. They will not apply fully unless New is
selected.

 Default pressure units on hydro page - default units that will show up on the hydro
page. Set this field to the units of the pressure gauge on your hydro test machine. Please
make sure that you select New (F5) command after changing this option for the changes
to take effect. They will not apply fully unless New is selected. Please also note that this
value is used for pressure gauge units on Multiple Jacket/Workstation systems.

 Default Reject % Permanent Expansion Value on hydro page - default value for Reject
% Permanent Expansion field on the Hydro page of the PSI form. Set this value to the
most commonly used value or set to blank if you want to enter the value for each test. This
value is also used by Multiple Jacket/Workstation module to set the Reject % Permanent
Expansion.

 Default Test Duration Value on hydro page - default value for Test Duration field on the
Hydro page of the PSI form. Set this value to the most commonly used test duration or set
to blank if you want to enter the value for each test. This value is also used by Multiple
Jacket/Workstation module to set the test duration.

1.9 Main Menu

The following section contains information on each item in the main menu. Some information
has been discussed in previous sections.

1.9.1 File Menu

1.9.1.1 New command

Use this command to create a new document in Visual Plus. You can also use F5 key to
activate this command. Typically this command is used before entering cylinder data and
performing an inspection to clear out all previous data.

You can open an existing document with the Open command .

1.9.1.2 Open command

Use this command to open an existing document stored on disk in the current window. You
can also use Ctrl-O key combination to activate this command. 

You can create new documents with the New command .

1.9.1.3 Open From Database command

Use this command to open a file from the database. All inspection records are stored in the
database even when the file is saved to a disk instead of directly into the database. Opening
a file does not invalidate Visual Plus calibration. The current calibration data will be stored in
memory and will be retrieved again when the next inspection starts.
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Please see page  for more information.

1.9.1.4 Save command

Use this command to save the active document to its current name and directory. You can
also use Ctrl-S key combination to activate this command. When you save a document for
the first time, Visual Plus displays the Save As dialog box so you can name your document.
If you want to change the name and directory of an existing document before you save it,
choose the Save As command . If you would like to store the file in the database, choose
the Save To Database command .

1.9.1.5 Save As command

Use this command to save and name the active document. You can also use F8 key to
activate this command. Visual Plus displays the Save As dialog box so you can name your
document.

To save a document with its existing name and directory, use the Save command .

Please note that Store inspection results in database option of Database settings dialog
 swaps F8 and Alt-F8 (Save As and Save To Database) keys so that files can be stored

directly into the database by pressing F8 without asking for a file name or location.

1.9.1.6 Save To Database command

Use this command to save a file to the database. You can also use Alt-F8 key combination
to activate this command. 

Please note that Store inspection results in database option of Database settings dialog
 swaps F8 and Alt-F8 (Save As and Save To Database) keys so that files can be stored

directly into the database by pressing F8 without asking for a file name or location.

1.9.1.7 Print command

Use this command to print a document. This command presents a Print dialog box, where
you may specify the range of pages to be printed, the number of copies, the destination
printer, and other printer setup options.

Please note that first page printed is always the eddy current inspection report. If the PSI or
VIP forms have been activated then the corresponding form will be printed as the second
page of the report. If you only want to print the PSI or VIP forms, select Print range on the 
Print dialog box as 'Pages from 2 to 2'.

1.9.1.8 Print Preview command

Use this command to display the active document as it would appear when printed. When
you choose this command, the main window will be replaced with a print preview window in
which one or two pages will be displayed in their printed format. The print preview toolbar
offers you options to view either one or two pages at a time; move back and forth through
the document; zoom in and out of pages; and initiate a print job.
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1.9.1.9 Print Setup command

Use this command to select a printer and a printer connection. This command presents a 
Print Setup dialog box, where you specify the printer and its connection.

1.9.1.10 Information command

Use this command to display the file information dialog. You can also use Ctrl-I key
combination to activate this command. The software and firmware version shown here is the
version that was used to record inspection for the currently loaded file. The person
performing inspection and calibration is also listed here.

1.9.1.11 Preferences command

Use this command to specify preferences for Visual Plus. Please see page  for more
information.

1.9.1.12 Shop Information command

Use this command to specify shop information such as name, address, etc. This command
will bring up the Shop Information dialog box. This information is then displayed on the
printout of the inspection. Please see page  for more information.

1.9.1.13 Send command

Use this command to send the active document through e-mail. This command presents a
mail window with the active document attached to it. You may then fill out the To field,
Subject field, and so on, and add text to the body of the message. When you are finished,
you can click the Send button to send the message.

1.9.1.14 File 1, 2, 3, 4 command

Use the numbers and filenames listed at the bottom of the File menu to open any of the
listed documents you closed. Choose the number that corresponds with the document you
want to open.

1.9.1.15 File Exit command

Use this command to end your Visual Plus session. You can also use the Close command
on the application Control menu. Visual Plus prompts you to save documents with unsaved
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changes.

Please note that calibration will be lost when VisualPlus 3 software closes. You will have to
run calibration again before performing any more inspections.

1.9.2 Edit Menu

1.9.2.1 Cut command

Use this command to remove the currently selected data from the document and put it on
the clipboard. This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

1.9.2.2 Copy command

Use this command to copy selected data onto the clipboard. This command is unavailable if
there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

1.9.2.3 Paste command

Use this command to insert a copy of the clipboard contents at the insertion point. This
command is unavailable if the clipboard is empty.

1.9.2.4 Inspector Editor command

Use this command to display the inspector editor dialog. Please see page  for more
information.

1.9.2.5 Customer Editor command

Use this command to display the customer editor dialog. Please see page  for more
information.

1.9.2.6 Selection Box Values command

Use this command to display the selection (drop-down) box values dialog. Please see page
 for more information.

1.9.3 View Menu

1.9.3.1 Toolbar command

Use this command to display and hide the toolbar, which includes buttons for some of the
most common commands in Visual Plus, such as File Open. A checkmark appears next to
the menu item when the toolbar is displayed.

27

28

30



Visual Plus Manual46

(c) 2006-08, Saryna Technologies LLC/Advanced Inspection Technology

1.9.3.2 Status Bar Command

Use this command to display and hide the status bar, which describes the action to be
executed by the selected menu item or pressed toolbar button, and keyboard latch state. A
checkmark appears next to the menu item when the status bar is displayed.

1.9.3.3 Display Type

Select one of the view types to be displayed in the graph view. The selected view type will
also be used during printing so it is important to have the correct view type displayed before
printing the test results.

1.9.3.3.1  Switch To Next View

Select this command to cycle through typical view types, please note that Calibration
Frequency Sweep and Accelerometer Calibration views are not typically used so they are
bypassed by this command. 

1.9.3.3.2  Overlay Threads

The Thread Overlay graph is useful for spotting features that coincide in the same angular
location from thread to thread. This view represents positions as looking down at the cylinder
crown, with the 0 degree position at the point where inspection started (this is typically the
first letter of the cylinder serial number). You can use Page Up/Down keys to zoom in/out of
data. Also Home/End keys can be used to move the baseline up and down.
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1.9.3.3.3  Individual Threads

The Individual Thread graph is useful for viewing a specific feature on a particular thread on
a polar type graph. This view represents positions as looking down at the cylinder crown,
with the 0 degree position at the point where inspection started (this is typically the first letter
of the cylinder serial number). You can use Page Up/Down keys to zoom in/out of data. Also
Home/End keys can be used to move the baseline up and down.

1.9.3.3.4  Linear Graph

The Multi-Row Linear graph is useful for viewing inspection results for the whole cylinder on
a linear type graph. This view stretches angular positions along the X axis, with the 0 degree
position on the left and 360 degree position on the right of each thread bracket. The zero
position is a point where inspection started (this is typically the first letter of the cylinder
serial number). You can use Page Up/Down keys to zoom in/out of data. Also Home/End
keys can be used to move the baseline up and down.

This view is the default view on the startup and this view should typically be used for printing
inspection results.
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1.9.3.3.5  Linear Single Row Graph

The Single Row Linear graph is useful for viewing inspection results in more detail on a
linear type graph. This view shows about four threads at a time and it stretches angular
positions along the X axis, with the 0 degree position on the left and 360 degree position on
the right of each thread bracket. The scrollbar on the bottom can be used to change the
currently visible threads. The zero position is a point where inspection started (this is
typically the first letter of the cylinder serial number). You can use Page Up/Down keys to
zoom in/out of data. Also Home/End keys can be used to move the baseline up and down.
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1.9.3.3.6  3D Spiral View

The 3D Spiral graph is useful for spotting features that coincide in the same angular location
from thread to thread. It can be easier to spot features of interest than on the Thread
Overlay graph because when the graph is rotated it provides better visual feedback on
feature locations. This view represents positions as looking down at the cylinder crown when
the blue line is perpendicular to the screen (visible as a dot). The cyan line indicates the
point where inspection started (this is typically the first letter of the cylinder serial number).
The positions values are in counter clockwise direction. You can use Page Up/Down keys to
zoom in/out of data. Also Home/End keys can be used to move the baseline up and down.
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1.9.3.3.7  Hydro View

The Hydro view shows the pressure and expansion values that were recoded during a hydro
test if a hydro module license with data acquisition was used. The left Y axis shows the
expansion values and the right Y axis shows the pressure. The X axis is time.
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1.9.3.3.8  Calibration Frequency Sweep

The calibration frequency sweep graph shows the raw calibration data that VisualPlus 3
uses to determine the correct operating frequency. This data is collected when transitioning
from the first to the second screen of the Calibration Wizard. This view should be only
consulted when troubleshooting potential problems. 

A normal graph is shown below. 

If the green line is flat all the way across the top that means that there is a problem with the
probe. The connection to the eddy current sensor in probe is lost or the sensor coil is
damaged.

1.9.3.3.9  Accelerometer Calibration

The Accelerometer Calibration view shows the results of probe position sensor calibration.
Normally the data should look like a green circle. The circle can be of different sizes
depending on the exact type of positions sensor used. For probe driver probes the graph will
not be perfectly circular if the probe driver is used during calibration. This data is collected
when you make a full probe revolution on the second screen of the Calibration  Wizard.
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1.9.3.4 Data Source

1.9.3.4.1  Calibration Data

Use this command to display calibration data for this file in the main window. Calibration is
always saved with each inspection file so that it could be reviewed later.

1.9.3.4.2  Inspection Data

Use this command to display recorded inspection data for this file in the main window. 

1.9.3.5 Zoom

1.9.3.5.1  In

Zoom in. This does not change the data itself but adjusts the scale of the Y axis.

1.9.3.5.2  Out

Zoom out. This does not change the data itself but adjusts the scale of the Y axis.

1.9.3.6 Baseline Removal
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1.9.3.6.1  Subtract More

Moves data on the graph down on the Y axis. The data itself is not changed as the scale is
adjusted to show correct Y axis values.

1.9.3.6.2  Subtract Less

Moves data on the graph up on the Y axis. The data itself is not changed as the scale is
adjusted to show correct Y axis values.

1.9.4 Inspection Menu

1.9.4.1 Calibration Wizard command

Use this command to start probe calibration. This command will bring up the Calibration
Wizard dialog box. For more information please see page .

1.9.4.2 Start Recording command

Use this command to start recording of data from the cylinder. Visual Plus will check to
make sure that all required fields are filled out before starting. An error message will be
displayed and the focus will be switched to the mandatory field that needs to be filled out.
For more information about inspection please see page .

Please make sure that the probe and cylinder are in horizontal position during recording.
PLEASE MAKE SURE THAT THE CYLINDER DOES NOT MOVE DURING INSPECTION.

Please always start recording with the probe threaded all the way into the cylinder (check
the signal bar to see if it's all the way to the top) and the white indicator line on the probe
aligned with the first letter of the cylinder's serial number. This will allow you to easily
compare recorded indications to the actual cylinder since the top position on the screen will
be aligned with the first letter of the serial number.

Most menu items (Open, Save, etc.) are disabled during recording to prevent data
corruption. Please stop recording before attempting to perform those operations.

Please note that you don't need to re-enter cylinder information if you want to re-run the
inspection. Pressing F6 or selecting Inspection->Start Recording will clear existing data
and start another recording. This only applies if the file has not been loaded from disk.
Changes to saved files are not allowed.

1.9.4.3 Stop Recording command

Use this command to stop recording of data from the cylinder. Please note that you will not
be able to change fields such as customer name, serial number, inspector, etc. after
recording has been completed. To start inspecting the next cylinder, first save the current
inspection using the Save command , then select New command  to clear all data,
enter information and start recording again.
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1.9.4.4 Inspection Fill Out PSI Form command

Use this command to fill out information for the PSI or VIP form.VisualPlus 3 displays the
PSI or VIP Form dialog box so you can enter form data. If this is the first time the form is
opened for this document, information such as customer name, serial number, inspector
name, and etc. will be transferred to the form from the main screen.

It is possible to automatically open the form after passing or failing inspection. To enable this
feature please enter the PSI Inspector Number for each inspector that has that number in
the Inspector Editor located under main menu Edit->Inspectors. Make sure that there is a
check mark on the If PSI number is entered, automatically display PSI form after
passing or failing inspection option in General page of Preferences dialog box accessible
through File->Preferences.

1.9.4.5 Inspection Pass command

Use this command to indicate that this inspection was completed successfully and that this
cylinder can be put back in service. Please only do this after completing both the eddy
current and visual inspection of the cylinder.

1.9.4.6 Inspection Fail command

Use this command to indicate that this inspection was not completed successfully and that
this cylinder should be removed from service. The cylinder condition and threading condition
on the PSI form will be automatically set to Unacceptable.

1.9.4.7 Analyze Inspection Results command

Use this command to analyze inspection results. This command finds indications in recorded
data and then applies a set of rules to determine if there is a possibility that the thread area
of the cylinder could be cracked. The results of the inspection will be added to the comment
section of the main window and if any cracks were detected the inspection status will be
changed to Failed. For more information about analysis of data please see page .

Typically this function is activated automatically after recording is stopped (usually via F7
key). If this does not happen automatically you can enable it by checking Perform
automatic analysis at the end of recording checkbox in General page of Preferences
dialog box accessible through File->Preferences.

Please always check recorded data manually and perform visual inspection of each
cylinder using Optical Plus  visual inspection system.

1.9.4.8 Find Indications command

Use this command to look for indications on recorded inspection results. Software will
typically find many small indications on dirty/noisy cylinders, they are not considered cracks
unless there is a required number of consecutive indications depending on the cylinder alloy.
Please use Analyze Inspection Results  command to detect cracks using latest definition
of a crack. For more information about analysis of data please see page .
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1.9.5 Database Menu

1.9.5.1 Search

Use this command to display the database search dialog box. Enter the search parameters
such as manufacturer, customer, inspector, serial number, dates, etc. Please remember that
returned records must satisfy all specified constraints. In effect, logically the AND operation
is perform on all specified parameters. Click OK to search the database. The results will be
shown in an Open From Database dialog.

Please note that it is possible to specify wildcards in the serial number field, use % wildcard
to replace any number of unknown characters, use _ (underscore) to replace a single
character. Any other standard Transact-SQL LIKE expression is acceptable.

Please see page  for more information.

1.9.5.2 Settings

Use this command to display the database settings dialog. Please select either the default
MS Access database file in the Visual Plus program folder or an ODBC DSN name. The
ODBC DSN name is an advanced option that allows you to place the database file anywhere
on your computer or on a network. In addition to MS Access database format, MS SQL
Server Express and MS SQL Server can be used. A MS SQL Server schema creation script
has been provided in the Visual Plus program directory as well as instruction on how to
setup the database and Visual Plus (Install MS SQL Server 2005 Express.pdf).
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 Store inspection results in database... - this option swaps F8 and Alt-F8 (Save As and
Save To Database) keys so that files can be stored directly into the database by just
pressing F8. There is no file name to be set so if all data has been entered on the main
screen the file is saved immediately. There is a confirmation box that shows up after the
file has been saved.

 Show list of previous inspections if the current cylinder has been inspected already
- this option brings up a list of previous inspection for the currently entered serial number
before inspection begins. This list will pop up right after you start recording data (typically
via F6 key). Take a look at the list and the previous results, print it if needed, then close
the window by clicking on the X in the right upper corner or just hit ESC. The VisualPlus 3
software will begin acquisition and you can start unscrewing the probe from the cylinder.
Please note that right after you close this window it may look like VisualPlus 3 is not doing
anything but as you turn the probe you will see that is actually recording data.

1.9.5.3 Backup All Data

This command performs database and data backup. Please see this  section for more
information.

1.9.5.4 Restore All Data

Enter topic text here.

1.9.6 Hydro Menu

1.9.6.1 Hydro Calibration Data Entry

Please see following page  for information on entering calibration data.

1.9.6.2 Data Entry Only

Please see following page  for information on performing data entry.
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1.9.6.3 Data Entry and Visual Inspection

Please see following page  for information on performing data entry.

1.9.6.4 Visual Inspection Only

Please see following page  for information on performing visual inspection.

1.9.6.5 Hydro Testing

Please see following page  for information on performing hydro test.

1.9.6.6 Test Report

Please see following page  for information on hydro test report.

1.9.6.7 Specifications

Please see following page  for information on performing data entry.

1.9.7 Help Menu

1.9.7.1 Help Topics command

Use this command to display the opening screen of help. From the opening screen, you can
jump to step-by-step instructions for using VisualPlus 3 and various types of reference
information.

Once you open help, you can click the Contents button whenever you want to return to the
opening screen.

1.9.7.2 What's This? Help command

Use this command to obtain help on some portion of VisualPlus 3 software. When you
choose the toolbar's Context Help button, the mouse pointer will change to an arrow and
question mark. Then click somewhere in the VisualPlus 3 window, such as another toolbar
button. The help topic will be shown for the item you clicked.

1.9.7.3 Enter License Key command

Use this command to enter a license key purchased for one of the add-on modules for
VisualPlus 3 software. A license key is required for optional modules such various hydro test
modules.

Please verify that the licensee and the key are entered EXACTLY as on the license
document/file/email that you received. It is preferable to select and copy to clipboard
a part of license email that contains Licensee: and Key: lines so that this information
is automatically populated when the dialog box opens.

Enter the licensee and the license key in to the edit boxs. Click OK to save the license key. 
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Verify that the correct module has been added in the following screen. If an error message
appears please make sure that the license key was typed in correctly.

1.9.7.4 Test Probe Accelerometer command

Use this command to display the probe accelerometer test dialog. You may be asked to
open this dialog by AIT to check probe position noise levels as well as probe function.
Normally you don't need to use this dialog box. Please note that if probe is connected the
numbers in all group boxes will be constantly changing. This is an indication that
communications with VisualPlus 3 acqusition module have been established and that
position resolving circuitry of the probe is functional. This does not diagnose probe sensor
problems.

To determine the probe accelerometer X/Y range press the Reset Range button, hold the
probe horizontally and make at least one full revolution. The X Range and Y Range values
should become stable, around 60 for newer probes and less for the older probes.
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1.9.7.5 About command

Use this command to display the copyright notice and version number of your copy of
VisualPlus 3.

1.10 Backing Up Data

To prevent data loss in an event of a hard disk malfunction or other problem it is
recommended to regularly backup VisualPlus 3 database and all data. It is also
recommended to enable backup reminders by selecting Database->Settings from the main
menu and making sure that 'Enable reminders to backup all data' check box is checked.
Set the 'Remind every X days' drop down box to the desired reminder interval.

To perform a backup, click on the  icon in the main toolbar or select
Database->Backup All Data from the main menu. Select the destination file (typically on a
removable media such as a USB flash drive or an external hard drive) and click Save. After
database backup completes successfully click OK.

Please note that this function only works for VisualPlus 3 setup to use a local
database in Visual Plus folder (this is the standard configuration). If you have
configured Visual Plus to use a remote database through an ODBC connection,
please backup the remote database regularly.

Please also note that this function DOES NOT backup your hydro module license key.
Please keep this information in a secure place. If you loose your license key please
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contact us for a replacement.

The database backup function backups following items into the specified file:

 visplus4.mdb file in Visual Plus directory. This file contains information about
inspectors, calibration and inspection records and may contain other information in
the future. The database may contain the actual recorded data or links to data files
for each inspection record depending on settings specified under 
Database->Settings. Please don't move files after they have been saved into the
data directory, if you do, you will not be able to pull up recorded data for those files
from the database report view. 

 Directory containing all data files. You can find out the location of this directory by
opening Visual Plus software and selecting File->Preferences from the main menu.
It is typically a directory called Data under Visual Plus directory. Keep in mind that if
you save files in directory other than this default directory you will need to back it up
also. 

 The HKEY_CURRENT_USER\Software\AIT\VISPlus registry key. Please don't
modify any registry values directly. All program settings are stored in this section of
the registry.

1.11 Troubleshooting

This section describes common problems with VisualPlus 3 and software.

1.11.1 Error opening communications port

Visual Plus software connects to Visual Plus instrument via an RS232 link. In order to
properly communicate with Visual Plus you must specify a COM port that the unit is
connected to. Typically for laptops it will be COM1, if you use a USB-Serial adapter the COM
port number is hard to predict. The best way to find out the COM port is to select 
File->Preferences from the main menu. Click on the Find button in the Visual Plus COM
Port Address group. If the unit is connected and USB-Serial adapter is installed properly the
VisualPlus 3 will find the correct COM port.
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If using Find fails to work try the following method:

1. Go to Start->Control Panel. 

2. Double-click System icon. 

3. Select Hardware tab. 

4. Click on Device Manager. 

5. Expand (double-click) the Ports (COM & LPT) item in the tree on the left side of the
window. 

6. The USB adapter or built in COM ports will be listed here. Write down available COM
port numbers. 

7. If USB Serial adapter has a yellow exclamation mark on it that means that the driver
was not installed properly. Please contact AIT for assistance with this problem.

8. Open Visual Plus software, go to File->Preferences, enter the first COM port
number that you wrote down in 'Visual Plus COM Port Address' field. If you now
know the COM port number please enter that number. Please enter the COM port
including the 'COM' prefix with no space between COM and the number. Just the
number is not enough. Click OK. 

9. Hit F4 to enter Calibration Wizard, enter Inspector Name and Probe Type, hit Next. If
Visual Plus is still unable to connect to the unit please try steps 7-8 with the rest of
the COM port numbers that you wrote down. If you are unable to connect on any of
them please try installing software on another computer or use another USB adapter
to see if the COM port might be defective. If you are unable to connect on two
computers or you don't have another computer please contact AIT for assistance.



Visual Plus Manual62

(c) 2006-08, Saryna Technologies LLC/Advanced Inspection Technology

1.11.2 Communication issues when using USB-Serial adapter

VisualPlus 3 software is extremely sensitive to the type of USB-Serial adapter used. 

WE ONLY RECOMMEND AND SUPPORT SIIG PART# JU-CB1S12-S3 USB TO SERIAL
ADAPTER.

Please note that other brands may not work at all or may work for a while and then cause
strange readings or loss of connection. There are some adapters that WILL NOT WORK for
sure with VisualPlus 3, they are: Radioshack USB-Serial adapter, IOGrear USB-Serial
adapter, etc.

Please note that some customers are reporting satisfactory results with Belkin USB-Serial
adapter, although it's not officially supported it is a good second choice if SIIG adapter is not
available.

Please see this section  for more up-to-date information on USB-Serial adapters.

1.11.3 Crash when starting the program

In rare cases the Microsoft Data Access Components (MDAC) can get corrupted. In this
case VisualPlus 3 software will crash before showing the main window. For operating
systems before Windows XP we recommend installing the latest version of MDAC
components from microsoft.com. 

Unfortunately MDAC cannot be easily re-installed on Windows XP. We found that following
instructions work well for repairing MDAC in this situation.

The following instructions have been reproduced with permission from macropool GmbH (
www.macropool.com). Please note that if the following instructions do not help macropool
offers an MDAC repair tool. The original source can be found here: 
http://www.macropool.com/en/download/mdac_xp_sp2.html

How to Repair MDAC 2.8 Under Windows
XP with SP2 Installed 
General Information

Windows XP with Service Pack 2 contains MDAC version 2.81, which is currently not
available for download at the Microsoft Web site as a standalone installation. If you try to
install MDAC 2.8, which is the latest available standalone download of MDAC, you will
receive a message that you already have a newer version of MDAC installed. Therefore, under
Windows XP SP2, you must manually repair MDAC 2.81 as outlined below. 

How to Repair MDAC 2.81 under Windows XP with SP2

1. In Windows Explorer, open the c:\Windows\Inf folder.

Note If you cannot see the c:\Windows\Inf folder, follow these steps: 
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a. On the desktop, double-click My Computer, and then on the Tools menu, click
Folder Options.

b. Click the View tab.

c. Under Advanced settings, select the Show hidden files and folders check box.

d. Clear the Hide extensions for known file types check box.

e. Click OK.

2. In the C:\Windows\Inf folder, right-click the Mdac.inf file, and then click Install. 

3. When you are prompted to insert the Windows XP SP2 CD, use one of the following
methods: 

I. If you have a Windows XP SP2 CD:

a. Insert the Windows XP Service Pack 2 CD in the CD or DVD drive. 
Note If a "Welcome to Microsoft Windows XP" message appears, click Exit. 

b. Click Browse.

c. In the File name box, type CD or DVD drive that contains the Windows XP
Service Pack 2 CD drive letter:\i386. For example, type d:\i386 if the Windows XP Service
Pack 2 CD is in drive D. 

d. Click Open.

II. If you do not have a Windows XP SP2 CD:

a. In the File name box, type %systemroot%\windows\servicepackfiles\i386,
and then click Open.

b. When prompted for adcjavas.inc, point to
C:\Windows\servicepackfiles\i386

Note: If you cannot find this folder put the Windows CD into your CD drive
and browse for that file.

c. When prompted for the file handler.reg, either point to C:\Program
Files\Common Files\System\msadc, or put the Windows XP CD in your CD-ROM drive.

d. When prompted for MDACRdMe.htm, point to C:\Program
Files\Common Files\System\Ado. If this file is not present rename the file
MDACReadme.htm to MDACRdMe.htm.

e.When prompted for oledbjvs.inc, point to C:\Program Files\Common
Files\System\Ole DB.

f. When prompted for mssoap1.dll, point to C:\Program Files\Common
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Files\MSSoap\Binaries.

g. When prompted for mssoapr.dll, point to C:\Program Files\Common

Files\MSSoap\Binaries (or below its subfolders).

4. You may also be prompted for the original Windows XP CD that was used to install the
operating system. 

a. Insert the Windows XP Service Pack 2 CD in the CD or DVD drive. 
Note If a "Welcome to Microsoft Windows XP" message appears, click Exit. 

b. Click Browse.

c. In the File name box, type CD or DVD drive that contains the Windows XP
Service Pack 2 CD drive letter:\i386. For example, type d:\i386 if the Windows XP Service
Pack 2 CD is in drive D. 

d. Click Open.

Note: In the case you cannot find those files in the given folders search the whole hard disk
for them.

1.11.4 Red power LED does not come on when VisualPlus unit is turned on

In some cases the firmware on VisualPlus 3 device can get corrupted. If the VisualPlus 3
unit is powered on but the red LED light is not lit AND software cannot connect to the
VisualPlus 3 unit the likely cause is firmware corruption.

If the red LED does not light but the unit works fine otherwise it could have either a burned
out LED or there could be a solder joint issue where the LED is soldered to the circuit board.
In this case please make a note of this problem during next calibration and we will fix the
light. This does not affect the accuracy of the unit and you can continue to use it until next
calibration.

In 99% of firmware corruption cases the firmware can be restored by re-flashing the unit
using VisualPlus 3 software.

Please follow this procedure to re-flash:

1. Make sure that VisualPlus 3 unit is powered on (front panel button is pushed in, power
supply is connected to the back of the unit).

2. Make sure that the unit is connected to the computer and that the correct COM port is set
in File-Preferences. If the unit was working fine previously then your COM port is already
set correctly.

3. Press Shift-Alt-Ctrl-U on the keyboard.

4. The firmware flash window should open and you should see check marks being marked
and progress bar moving. Wait until flash completed successfully message. The red LED
light should come on now and you should be able to do calibration and inspections.

If the firmware flash process does not start automatically, try to turn VisualPlus 3 off and
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then back on. If re-flashing still does not start please contact support.

PLEASE NOTE THAT SOME UNSUPPORTED USB-SERIAL ADAPTERS WORK FINE
FOR INSPECTIONS AND CALIBRATION BUT WILL NOT WORK PROPERLY FOR
FIRMWARE RE-FLASHING.

To get around this problem please either purchase a supported USB-Serial adapter or install
VisualPlus 3 software on another computer with a serial port, re-flash the unit there and then
put it back on the original computer.

1.11.5 Crash when printing

If VisualPlus 3 software crashes when you attempt to print out an inspection please make
sure that the VisualPlus 3 software version is 3.7.3.6 or later.

1.11.6 OBDC Driver Errors

You may get this error if you are trying to run VisualPlus 3 under Windows 98 First Edition
software. VisualPlus 3 requires Microsoft Data Access Components (MDAC) 2.6 or later to
be installed on your system for it to work properly. To fix this problem, download and install
MDAC component from our website or directly from microsoft (go to www.microsoft.com and
type in MDAC in the search box, then select MDAC Downloads). This only applies to
Windows 98 First Edition but if you are getting this error with later versions you may want to
try installing the latest MDAC to make sure that you don't have a corrupted driver.

1.11.7 Invalid attribute/option identifier error message

Visual Plus stores information about inspectors, calibration and inspection records in a
database file called visplus4.mdb located in Visual Plus directory. In Windows 2000/XP you
may get an error during calibration and inspection if the Administrator installed Visual Plus
software and another user without administrative privileges attempts to run Visual Plus. This
happens because other users do not have Full Access permission to the database file.

To solve this problem you need to give Full Access permission to the Users security group.
In addition to Users you may need to give the same permission to the Domain Users group
if you log in on a specific domain. Depending on how a network is setup you may need to
grant this permission to other groups. Please consult your system administrator for help. 

To set permissions, log in as administrator and right mouse click on visplus4.mdb usually
located in C:\Programs Files\ Visual Plus directory. Select Properties menu item, select
Security tab. If the tab is not visible please read the next paragraph. Click on Add, select or
type in Users. Click on the added Users group and click on Full Access box below. Click
OK. Other users of this computer can now use Visual Plus. You can do the same for
Domain Users if you log onto a domain. 

In Windows XP, if a machine is not a part of a domain it will typically not display the 
Security tab when you right mouse click on a file and select Properties. To get that tab to
show up you need to go to Tools->Folder Options in Windows Explorer. Click on the View
tab, scroll all the way down to Use simple file sharing and make sure that it IS NOT
CHECKED.

http://www.microsoft.com
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1.12 Calibration Standard Drawings

According to Final Rule 49 CFR Parts 173 and 180 a drawing of calibration standard
(reference ring) must be kept on site. Please print out drawings for probe types used in your
facility from the table below and keep on file. The relevant sections of CFR Part 180 are
reproduced below.

Appendix C to Part 180—Eddy Current Examination With Visual Inspection for DOT 3AL Cylinders
Manufactured of Aluminum Alloy 6351–T6
.....
4. Eddy Current Reference Ring. The reference ring must be produced to represent each cylinder to be tested. The reference
ring must include artificial notches to simulate a neck crack. The size of the artificial notch (depth and length) must have a
depth less than or equal to 1⁄3 of the wall thickness of the neck and a length greater than or equal to two threads. The standard
reference must have a drawing that includes the diameter of the ring, and depth and length of each notch.
.....
7. Eddy current examination reporting and record retention requirements. Daily records of eddy current examinations must be
maintained by the person who performs the requalification until either the expiration of the requalification period or until the
cylinder is again requalified, whichever occurs first. These records shall be made available for inspection by a representative of
the Department on request. Eddy current examination records shall contain the following information:
(i) Specification of each standard reference ring used to perform the eddy current examination.
(ii) DOT specification or exemption number of the cylinder; manufacturer’s name or symbol; owner’s name or symbol, if
present; serial number; and, date of manufacture.
(iii) Name of test operator performing the eddy current examination. 
(iv) Date of eddy current examination. 
(vi) Acceptance/condemnation results (e.g. pass or fail).
(vii) Retester identification number.

Calibration Standard Drawing Links:

#1 - SCUBA 0.75-14NPSM

#2 - SCBA 0.75-16UNF

#3 - SCBA 1.125-12UNF

#4 - SCBA 0.875-14UNF

#5 - Paintball-SpareAir 0.625-18UNF

#6 - 0.75-14NGT

M18 - M18x1.5

M25 - M25x2.0
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2 Visual Plus Hydro Testing

VisualPlus 3 software is capable of tracking and recording hydro testing data. There are
several options that are available depending on the type of license that you purchase.

 Manual hydro data entry - in this case a page is added to the PSI form that allows you to
enter the hydro test data manually. Cylinder information is entered into tabs on the PSI
form. On the last Hydro tab the operator performs the hydro test and enters the results
(actual pressure, total and permanent expansion) into the dialog box. The results of the
test can be viewed through the Hydro Test Report (for multiple tests), by printing out the
PSI form (a Hydro section is added to the PSI form for files that contain this information),
or the test results can be printed out in DOT compliant manner.

 Single jacket/single workstation - in this configuration VisualPlus 3 will record the test
results utilizing a digital scale and a digital pressure gauge. The interface is similar to the
manual configuration above with test initiated by clicking Measure with VisualPlus Hydro
button on the Hydro tab of the PSI form. The results are automatically entered into the
dialog box and can be viewed by any of the methods mentioned for the manual
configuration. The digital pressure gauge and digital scale must be connected to the
computer running VisualPlus 3. It is also possible to use special hydro data entry/visual
inspection/hydro testing dialogs from the multiple workstation method below. Please note
that if you plan to use separate workstations for data entry/visual inspection and hydro
testing you should purchase the multiple jacket/multiple workstations license as described
below but mention that you only have a single jacket.

 Multiple jacket/multiple workstations - this configuration is used for higher throughput
facilities that want to break up hydro test into two or three steps that can be done in
parallel. For example, a single workstation with a label printer is setup for data entry. The
cylinder info is entered into a special form which produces a barcode label after saving the
info into the database. The cylinder then passes on to visual inspection station. At this
station the barcode is scanned and the cylinder is either passed, rejected or condemned.
All passing cylinders are then moved to the hydro test station where each tank barcode is
scanned and test is performed. All resulting data is stored in the database. The results for
each date can be printed out in a DOT compliant format. It is possible to have multiple
data entry, multiple visual inspection, and multiple hydro test stations.

2.1 Configuring Software

To enable VisualPlus 3 software for any of the modules (manual, single jacket/workstation,
and multiple jacket/workstation) a license key must be entered into the software.  

1. Click on Help->Enter License Key, type or copy/paste the license key that you purchased
into the dialog box and click OK. Please see section   for information on how to easily
copy those fields from an email.

2. It is highly recommended to switch VisualPlus 3 software to store raw data in the
database instead of Data folder. Should you decide to upgrade to a multiple jacket/
workstation configuration later this option will preserve all raw data. To switch to this mode
click on Database->Settings from the main menu and make sure that Store inspection
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results in database option is checked. You MUST choose this setting if you are using
Multiple Jacket/Multiple Workstation Module.

3. If using a Single or Multiple jacket/workstation license please configure the COM ports
used for the digital pressure gauge and the scales in File->Preferences->Hydro. You
can also use the same page for setting additional parameters and defaults, such as the
country and the default units. See page  for more info.

2.2 Entering Calibration Data

Before performing hydro testing the system should be checked with a calibrated cylinder
each day. VisualPlus 3 software does not perform this function automatically but allows the
results of calibration to be entered manually so that they show up on the Hydro Test Report.
This is applicable to all hydro modules, including the manual data entry module.

1. To enter the calibration data, select Hydro->Hydro Calibration Data Entry from the main
menu. Enter the hydro operator and supervisor names and click OK.

    

2. In the following dialog box, enter the calibration cylinder Serial #, Owner (typically your
business name) and the test results. If there are any comments they can be entered into
the Remarks field. It is common to enter the jacket number in to the remarks field for
multi-jacket systems. If calibration was performed on jacket #1, J1 is entered into the
Remarks field in this case.

40
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3. Click Store Record or press F2 to record the data. The calibration results fields will be
reset and ready for entry of the next calibration data point. The previously entered record
will be shown in the Log section until this dialog box is closed.

4. Click Close after all calibration data have been entered.

5. The resulting entries can be verified by selecting Hydro->Test Report. An example of
calibration entries is shown below:

    

2.3 Hydro Test Result Codes

A - Pass

B - Failed, Permanent Expansion

C - Failed, Elastic Expansion

D - Failed, Visible Defects or Eddy Current Failure

E - Equipment Failure

2.4 Hydro Test Report

The results of hydro tests can be viewed in the Hydro Test Report screen. In a typical
setting the test report should be displayed and printed at the end of each day. 
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To print this report follow those steps:

1. Select Hydro->Test Report from the main menu.

    

2. Click Today icon to narrow down the list of tests to all tests that were done today. If you
would like to print out a report for another day or range of dates you can use Yesterday
or other icons or define the report date range using the Query button.

3. Click Printer icon to print out the report, it will be formatted in a DOT compliant manner.
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The hydro test report is similar to the Inspection List report with the following differences:

 The list of columns and column widths is always loaded from 'Hydro Test Report.vpr' file in
the VisualPlus 3 application folder. If you need to make changes to the list of columns or
column widths, first make those changes and then select Save Report icon and overwrite
the 'Hydro Test Report.vpr' file in the VisualPlus 3 application folder.

 When printing, the report is formatted in a special format, with all appropriate notices and
signature block instead of a simple list.

For Single or Multiple Jacket/workstation modules the actual recording of expansion and test
pressure graph can be shown by double-clicking on any entry in the Hydro Test Report: 

2.5 Specifications

When VisualPlus 3 software calculates the specified (target) pressure for a hydro test it
defaults to 5/3 of the cylinder working pressure in USA and for pre-1993 cylinders in
Canada. The default for 1993 and later cylinders in Canada is 3/2 of the working pressure.
Some Special Permits require different target pressure. You can specify those Special
Permits in this window so that the correct target pressure is used. Once the data has been
specified for a Specification/Special Permit it will override any defaults for calculating
specified (target) pressure.
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 To add a new Specification/Special Permit click Add New Record. Select or enter the
Specification/Special Permit into the combo box. Enter the numerator and denominator of
the ratio for calculation of target pressure. The cylinder working pressure is multiplied by
this ratio to calculate the correct specified (target) pressure. Click Save to save the data.

   

 To edit an existing record, first click on the record to select it and then click Edit Selected
Record. Modify the necessary fields and click Save to store the changes.

 To delete an existing record, first click on the record to select it and then click Delete
Selected Record. 

2.6 Manual Hydro Module

Manual hydro module enables the 'Hydro' page in the PSI inspection form. It is intended for
single jacket manual systems. 

 Please make sure that you enter calibration data as described in the Entering
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Calibration Data  section before testing any cylinders for each day. This way the
calibration data will show up at the top of the hydro test report.

 If you intend to perform eddy current inspection please calibrate the VisualPlus 3
unit at the beginning of the day or when switching to different size probe. 

 Please make sure that the name of the hydro test inspector has been entered either
through Inspected By field on the main screen or by selecting Edit->Inspectors from
the main menu. The Tested By field on the Hydro page is a drop down box which
only allows selection of an existing inspector name.

A typical work flow in this situation is as follows (for each cylinder):

1. Start a new file (click File->New or F5, you can also click on the New icon on the toolbar).

2. Fill out the General page of the PSI form (click Inspection->Fill Out Inspection Form or
F3, you can also click on the Inspection Form icon on the toolbar). Please make sure
that you enter the cylinder service pressure and pressure units into the Pressure field. The
contents of this field are used to calculate the default Specified (Target) Test Pressure for
the hydro test. Please also note that the Mfg. Date field is used to calculate the correct
Specified Test Pressure in Canada.

    

3. If eddy current inspection is required click OK to close the PSI form. Perform the eddy
current inspection, if the tank passes inspection, press F10 to pass eddy current part of
inspection and return to the External page of the PSI form (press F3 and then click on
External tab). If the tank fails, return straight to the Condition page of the PSI form and
select Unacceptable under Cylinder Condition, fill out the rest of this page and then
advance to Hydro page. Please skip the following item in this situation, it is not necessary
to fill out External to Valve pages if the tank is going to fail anyway.
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4. If tank has passed eddy current inspection then fill out External, Internal, Threading, and
Valve pages. 

5. On the Condition page, if you select Marginal under Cylinder Condition and then select
inspector name under Tested By field of the Hydro page that would create a 'Reject' entry
in the Hydro log when this file is saved. If Unacceptable is selected then a 'Condemn'
entry is created. If Acceptable is select then the final test result will be determined by the
Hydro test.

    

6. Click on Hydro tab. Under Tested By field select the name of the person performing the
hydro test. If this field is set to 'Not Tested' there will be no hydro record created and
nothing will show up in the Hydro Test report. This field must be set to the inspector name
even if the outcome of the test is 'Reject' or 'Condemn'.

7. Please double-check the Specified Pressure field. It is calculated as 5/3 of the service
pressure entered on the General page of the PSI form for USA and either as 5/3 for pre-
1993 cylinders or 3/2 for 1993 and later cylinders in Canada. Please note that if a cylinder
is stamped with test pressure (TP) you need to change this field to reflect the specified
test pressure. Also, if re-testing a cylinder that failed because of equipment failure the
specified pressure should be increased according to inspection guidelines. 

8. Double check the Test Duration and Reject % Permanent Expansion fields, especially if
they were set up to be set to a default value.

9. Perform the hydro test on the cylinder and enter the information into the form. Based on
the entered Reject Elastic Expansion (REE) and Reject % Permanent Expansion fields
the software will calculate if the cylinder passes or fails the hydro test. If the Elastic
expansion is greater than REE then the Cylinder is failed with test code 'C - Fail,
Excessive Elastic'. If the REE is zero then this comparison is not performed and will not
affect the outcome of the test. The REE column in the Hydro Test report will have N/A in
this case. If the % Permanent expansion is greater than Reject % Permanent Expansion
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then the cylinder is failed with test code 'B - Fail, Permanent Expansion'. The Elastic and
% Permanent fields are calculated automatically. The result of the test is shown in the
Test Result Code field. If there was an equipment failure please check the 'Equipment
Failure' checkbox. This will create an entry in the Hydro Test report with the test code 'E'.
Enter any remarks into the Remarks field. If this test is a re-test of a previous hydro test
then make sure to check the checkbox under 'If retest...' group and specify the date of the
previous test.

    

10.Click OK to close the PSI Form, then press F8 to save the results into the database. You
will not be able to make any changes to the stored record after it has been saved so
please double check all data before saving. Unless you save the data no record will be
created. Please remember to save each inspection!

11. Repeat from step 1 for each following cylinder.

2.7 Single Jacket/Single Workstation Module

Single Jacket/Single Workstation module allows direct measurement of data from a digital
pressure gauge and a digital scale by clicking on Measure with VisualPlus Hydro button.
This button will be illuminated if you purchased a Single Jacket/Workstation license key. The
measured actual pressure, total and permanent expansion will be transferred into the
appropriate fields of the Hydro page on the PSI form after the test. Please see the following 
section  for more info on the test process.78
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2.8 Multiple Jacket/Multiple Workstation Module

Multiple Jacket/Multiple Workstation module enables 'Data Entry Only', 'Data Entry and
Visual Inspection', 'Visual Inspection Only', and 'Hydro Testing' options on the Hydro menu
of the main menu.

 Please make sure that you enter calibration data as described in the 'Entering
Calibration Data' section  before testing any cylinders for each day. This way the
calibration data will show up at the top of the hydro test report.

 If you intend to perform eddy current inspection please calibrate the VisualPlus 3
unit at the beginning of the day or when switching to different size probe. If you
attempt to calibrate VisualPlus 3 during Date Entry or Visual Inspection you will
have to re-enter the cylinder serial number, manufacturer, and manufacturing date
on the main screen.

2.8.1 Entering Cylinder Data

Select Hydro-Data Entry Only or Hydro->Data Entry and Visual Inspection from the
main menu on the computer that will be used for data entry. Enter the cylinder information
and press F2 to store data in the database, a barcode sticker will be printed and it should be
affixed to the tank before moving it to the visual inspection or the hydro stations.
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If performing visual inspection during data entry please also select the visual inspection
result before saving the data. Please see the next section about inspection cylinders made
from 6351 alloy.
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2.8.2 Performing Visual Inspection

Select Hydro->Visual Inspection Only from the main menu on the computer that will be
used for visual inspections. 

1. Scan the barcode that was affixed to the cylinder at the data entry station or manually
type in the cylinder serial number into the Serial # field. Hit Enter if entering the serial
number manually.

    

2. Perform visual inspection and select the result (Pass, Reject, or Condemn). If the cylinder
is made from 6351 alloy the VisualPlus 3 will require that you press Inspect with Visual
Plus button and perform an eddy current inspection before passing this cylinder. After
eddy current inspection has been completed hit F8 to return to the Visual Inspection
screen.

    

3. Press F2 to store data in the database before moving the cylinder to the hydro station.

2.8.3 Performing Hydro Test

Select Hydro-Hydro Testing to bring up the Hydro Test screen and follow those steps to
perform hydro testing:

1. Scan barcode or enter cylinder serial numbers in to the Serial # field for each jacket. The
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cylinder information is retrieved for each cylinder. The cylinder must have passed the
visual inspection, testing of condemned or rejected cylinders will not be allowed.

    

2. Click Start Test. The system will prompt for the jackets to be pressurized by the operator.
Apply pressure to the cylinders being tested.

    

3. Once the target pressure has been achieved the system performs total expansion
measurement.
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4. Once total expansion has been measured, the system prompts the operator to release
pressure and measures permanent expansion once the pressure drops to zero and scales
stabilize.

    

5. After test has been completed the operator can review the graph before going to the
results screen. Click Finish when done reviewing the results.
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6. After clicking Finish the results screen is shown which now contains the measured data,
calculated elastic and percent permanent expansion results, and the test result code. The
operator can enter any comments into the remarks field before saving data for all tanks
into the database. If a problem occured in one or more jackets the operator can change
the test result for each jacket by clicking on the ... button in the Result field of each
affected jacket.

    

7. Click on Save Results of press F8 to save the results into the database. They will show
up on the Hydro Test Report after this point.
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2.9 Hardware Requirements and Setup

Hardware list and configuration information for Single Jacket/Workstation and Multiple
Jacket/Workstation license is provided in this section.

2.9.1 Required Hardware

To use Visual Plus Hydro Testing module in Single Jacket/Workstation or Multiple Jacket/
Workstation mode the following hardware is required:

 Acculab VIC-5101 Scale with YADAP-RS serial interface (one for each jacket of your
system)

 Red Lion Pressure Gauge Meter (Part# PAXP0000) with serial interface (Part#
PAXCDC2C) and Turck 7500psi pressure sensor (Part# PT7500PSIG-13-LI3-H1131).
Depending on how you are planning to mount the gauge you may want to consider an
enclosure for the pressure meter (Red Lion Part# ENC5A000)

 USB-Serial Adapter(s). If your computer does not have enough built-in serial (9 pin male)
ports (many newer computers do not have them) you will need a USB to multiple serial
port adapter or several single USB-Serial adapters. For multiple jacket configurations (4 or
more jackets) we recommend using an eight port USB to serial adapter (Part# USBG-8X-
RS232) from CableMax. It can be ordered here: http://www.cablemax.com/serial-adapters/
usb-to-8port_rs232_adapter.html. For one to three jacket configuration either the eight
port module can be used or a less expensive four port (Part# USBG-4X-RS232) adapter
can be used. If using several single USB-Serial adapters we recommend SIIG USB-Serial
adapter (Part# JU-CB1S12-S3).

The following additional hardware is recommended for the Multiple Jacket/Workstation
mode:

 Barcode scanners (2pcs). One for Visual Inspection workstation and one for Hydro Test
workstation. Symbol LS 2208 Scanner Multiple Interface Scanner (USB Kit, Cable, Stand
and Software) - Part# LS2208-SR20001R-UR at www.barcodespot.com

 Brother QL-500 or QL-550 (this printer has automatic label cutter) label printer for each
data entry station. 

 Brother DK-1203 labels. Those are 0.67" x 3.44" file folder paper labels.

 For Multiple Jacket/Workstation license we recommend only using hardwired connections
between data entry stations, visual inspection stations, hydro test stations and the server.
In addition, it is preferable to contain those stations within a single private network.

http://www.cablemax.com/serial-adapters/usb-to-8port_rs232_adapter.html.
http://www.cablemax.com/serial-adapters/usb-to-8port_rs232_adapter.html.
http://www.barcodespot.com
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2.9.2 Configuring Hardware

It is necessary to modify Acculab scale configuration for all scales to allow the software to
poll the current weight and change the baud rate to 19200bps with no flow control. Please
make sure that serial interface has been installed in each scale before starting this
procedure. 

1. Turn the scale off.

2. Turn the scale on and while all digits are displayed, press and hold Zero until '1' is
displayed on the screen.

3. Press F button (usually twice) so that display is showing '6'.

4. Press Enter. The display should show '6. 1.'

5. Press Enter. The display should show '6. 1. 2 o'

6. Press F button (usually three times) so that display is showing '6. 1. 1'

7. Press Enter and hold until the display shows '6. 1. 1 o'

8. Press Zero twice. The display should show '6.'

9. Press F button (usually four times) so that display is showing '5.'

10. Press Enter. The display should show '5.1.'

11. Press Enter. The display should show '5.1.4 o'

12. Press F button (usually four times) so that display is showing '5.1.8'

13. Press Enter and hold until the display shows '5.1.8 o'

14. Press Zero once. The display should show '5.1.'

15. Press F button (usually three times) so that display is showing '5.4.'

16. Press Enter. The display should show '5.4.2 o'.

17. Press F button (usually once) so that display is showing '5.4.3'

18. Press Enter and hold until the display shows '5.4.3 o'

19.Press and hold Zero until the scale turns off, it will turn back on by itself.

The scale is now configured for acquisition. To verify this configuration you can follow steps
1 through 5. At step 5 the scale should show '6. 1. 1 o'.  Similarly check for None hardware
handshake (5.4.3 o) and 19200 baud (5.1.8 o). that If this is correct you can turn the scale
off and then back on.

Double check that the scale is configured to output data in grams:

1. Turn the scale off.
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2. Turn the scale on and while all digits are displayed, press and hold Zero until '1' is
displayed on the screen.

3. Press Enter. The display should show '1. 1.'

20.Press F button (usually five times) so that display is showing '1. 7.'

21. Press Enter. The display should show '1. 7. 2 o'.

22. If the display is correct then the scale is configured for gram output and you can turn the
scale off and then back on. If it shows something else then follow instructions in the scale
user manual to set units to grams.

The communication parameters should be set to the following (this is different from factory
defaults): 19200 baud, odd parity, 7 bits, 1 stop bit, no handshake. 
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3 Visual Plus Database

VisualPlus 3 database contains information about customers, inspectors, calibration and
inspection records, etc. It is normally stored in the visplus4.mdb file in the VisualPlus 3
program directory (typically C:\Program Files\Visual Plus).

VisualPlus 3 can also be setup to store data into an MS SQL Server or MS SQL Server
Express database. Please note that such an installation requires technical expertise in MS
SQL Server and is not recommended for typical users. 

3.1 Upgrading from MS Access to MS SQL Server Database

To upgrade from standard MS Access based database to MS SQL server database you will
need MS Access application. The following procedure has been tested with MS Access 2003
and MS SQL Server Express 2005. If using other versions of those produces the screens
may differ.

Please note that if you already have existing data in the MS Access database this
procedure is the only way to transfer data to the MS SQL database. 

1. Please make sure that you DOWNLOAD AND RUN the latest version of VisualPlus 3
software available on www.visualplus.net. This will update your MS Access database to
the latest version.

2. Open visplus4.mdb file (typically located VisualPlus 3 application folder - usually in C:
\Program Files\Visual Plus) in MS Access.

    

3. Select Tools->Database Utilities->Upsizing Wizard. Select Create new database and
click Next.

http://www.visualplus.net.
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4. Select the SQL Server (SQL Server software must be already installed on that computer)
and specify either Use Trusted Connection or provide login and password for a user with
CREATE DATABASE privileges on that server. Select a name for your VisualPlus 3
database. Typically this can be set to vp. Click Next.

    

5. Click on the >> button to select all tables to be exported to SQL Server and click Next.
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6. Make sure that Only create the table structure; don't upsize any data check box is
NOT checked on the next screen. Also make sure that Add  timestamp fields to tables
is set to 'No, Never'. Make sure that all other options are set as on the screenshot below.
Click Next.

    

7. Select options on the following page as shown below, typically those are the default
options. Click Next.
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8. Click Finish on the following page to start the conversion.

    

9. Close the MS Access once Upsizing Wizard is done exporting data. 

10. You will now need to run a script to fix datatypes and constraints that Upsizing Wizard
creates. Run SQLServerFixTablesAfterAccess2003UpsizeWizard.sql script (located in
VisualPlus 3 application folder) using MS SQL Server Management Studio or command
line. It is written for database named vp. If you use another database name please edit
the first line of this file to change vp to your database name. Make sure that you get
Command(s) completed successfully message.
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11.See the next section on how to configure client computers to access your new database.

3.2 Setting up clients to connect to MS SQL Database

Once MS SQL database has been created either using the Upsizing Wizard or by running
SQLServerDatabaseCreationScript.sql each client computer will have to be configured to
access it.

The following procedure must be repeated on every computer that will be accessing the MS
SQL database.

Create the System DSN for VisualPlus 3 database:

1. Go to Start->Control Panels->Administrative Tools->Data Sources (OBDC). If you are
using Windows XP and you are not in Classic View follow this sequence: Start->Control
Panel->Perfomance and Maintenance->Administrative Tools->Data Sources (OBDC).
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2. Click on System DSN tab, click on Add button. Select SQL Server driver. Click Finish.

    

3. Enter the name for VisualPlus 3 database, for example, VP3Database. Enter the
description and select server. For client PCs, select the server name from the drop down
menu.  If installing on the server itself please make sure that you select the actual
server name and NOT the (local) option. Click Next.
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4. Select the appropriate authentication method on the following screen. This will depend on
how security is setup on your database server. Typically you will need to click on Client
Configuration to specify the port used by the SQL Server.

    

5. On the Client Configuration screen select the appropriate method of communications
(typically TCP/IP), uncheck Dynamically determine port and enter the port number that
is used by your database server. Click OK. Click Next.
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6. On the following screen make sure that Change the default database to box is checked
and select the VisualPlus 3 database from the drop down list below. The database name
in most cases will be vp. This is the case if this is the name you used in Upsizing Wizard
or if you used the database creation script without any modifications. Leave everything
else at default settings and click Next.

    

7. Click Next again on the following screen without changing anything. Click Finish.
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8. Click on the Test Data Source button on the following screen. The window should show
TEST COMPLETED SUCCESSFULLY message. Click OK. Click OK again.

    

9. Close the ODBC Data Source Administrator window by clicking OK.

Select the created ODBC name in VisualPlus 3 software.

1. In VisualPlus 3 software select Database->Settings from the main menu.



Visual Plus Manual94

(c) 2006-08, Saryna Technologies LLC/Advanced Inspection Technology

    

2. Click on ODBC DSN radio button and click on Browse, click on Machine Data Source
tab. Select the ODBC name that you created in previous steps. In this example it will be 
VP3Database. Click OK.

    

3. Enter login parameters depending on the way security is setup on your database server
and click OK.
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4. Make sure that both checkboxes are checked on the database settings screen and click 
OK.

    

5. A message will come up with notification that VisualPlus must exit for database changes
to take effect. Click OK and bring up VisualPlus 3 software again. It should be now
connected to the SQL Server database. Please verify that the data has been transferred
by  viewing the customer and inspector lists. Also check the inspection records.

    

3.3 Backing up MS SQL VisualPlus database

It is very important to keep regular backups of VisualPlus 3 database. This is especially
important when storing hydrostatic test data if the reports are not printed out daily.

Follow those steps to backup VisualPlus 3 database stored on an MS SQL server:

1. Run MS SQL Server Management Studio. Connect to the server where VisualPlus 3
database is located.
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2. Expand the Databases item in the Object Explorer on the left. Right-click on the
VisualPlus 3 database. It is typically called 'vp'. Select Tasks->Backup from the menu.

3. Set the backup type to Full. If the destination location for the backup is not set correctly
click on Add and select the destination location for the backup.

     

4. Remove the incorrect destination by selecting it first and then clicking Remove button.
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5. Click on Options item under Select a page pane on the left. Select Overwrite all existing
backup sets. Check Verify backup when finished and Perform checksum before writing to
media. Click OK to start backup.
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6. Make sure that successful backup message appears.

    

The database is now backed up to the destination folder. Please copy the backup file
(usually named vp.bak) to an offline storage location.

3.4 Upgrading VisualPlus in multi-user environment

When VisualPlus 3 is opened it checks the database schema number and if it determines
that the schema is older than the current schema for this version of  VisualPlus 3 it will
perform schema update. This update is performed automatically without prompt. It is
therefore very important to follow procedure below to make sure that upgrade is done
correctly. This procedure applies for MS SQL Server installations.

1. Notify all users about upcoming upgrade. Ideally the upgrade should be down after-hours
so that when database is put into RESTRICTED_USER state the users do not loose any
data. After the upgrade the users will have to download and install the latest client
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software before performing inspections.

2. It is important to make sure that in a multi-user environment all currently logged in users
are first logged off and the database is switched to RESTRICTED_USER access state. In
this state only users with db_owner, dbcreator, or sysadmin roles can access the
database. Run MS SQL Server Management Studio Express. Switch to the
RESTRICTED_USER state by right mouse clicking the vp database and selecting
Properties. Select Options on the left upper panel and scroll down to Restrict Access item
(last item). Change this item from MULTI_USER to RESTRICTED_USER. All users will be
logged of the database and database will be put into Restricted state.

    

3. If database is configured for access via SQL Server Authentication it is important to verify
that there is a login available that has db_owner role for the VisualPlus 3 database set.
Typically this user is 'sa', please verify that you know the password for this login (it can be
reset by logging into database from the server with Windows Authentication method) and
that 'sa' login has a check in the Map column of the User Mapping page.
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4. Install the latest VisualPlus 3 client on a computer that has been setup to access the
production database. 

5. Run VisualPlus 3 client. Login with 'sa' (or other login that has db_datareader AND
db_datawriter AND db_ddladmin OR db_owner permission set). If no error messages are
displayed and the main window opens that means that schema upgrade completed
successfully. To double-check, press Alt-O and you should see the list of latest
inspections.

6. Switch the database to MULTI_USER as in step 1. Close VisualPlus 3 client, and run it
again. This time log in with normal login that is used to access the database routinely.
This login should have db_datareader and db_datawriter permissions set for the
production database.

7. Verify that no error messages are shown and that inspection records appear in response
to Alt-O.

8. Notify all users to download and install the latest VisualPlus 3 client before attempting to
perform any inspections.

3.5 Protecting Inspector and Shop Records

In multi-user environments it is very easy for inspector records to become disorganized if
inspectors do not select correct names from drop down boxes. Multiple records could be
created for the same inspector. In addition, the shop information could be deleted by a
careless inspector. 

To minimize chances of this happening you can set a simple password to lock out access to
inspector editor and to block access to delete shop function. In addition, the drop down
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boxes for inspector names will become drop down list boxes, which means that a new
inspector cannot be added through the main screen or the calibration wizard. They will have
to be added through the inspector editor using the password. 

To set a password run the following SQL statement against the database (Microsoft SQL
Server):

INSERT INTO Settings (Name, Val) VALUES ('DeleteButtonPassword', 'password')

Replace password with the password of choice. Please note that the password is stored in
plain text is not meant as a security feature. It is there to prevent accidental changes.

If you are using Microsoft Access database you can open the 'visplus4.mdb' file using
Microsoft Access, double-click on the Settings table. Type in 'DeleteButtonPassword'
(without the quotes) into the blank cell in the Name column to the right of (AutoNumber).

Enter the password that you would like to use into the Val column on this newly created item
(in the following example the new password will be 'pass1234'.

Click on any cell and then close Microsoft Access to make sure that changes have been
saved.
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3.6 Schema

VisualPlus 3 database schema:



Visual Plus Automation Interface 103

(c) 2006-08, Saryna Technologies LLC/Advanced Inspection Technology

4 Visual Plus Automation Interface

VisualPlus 3 software can be launched via OLE Automation interface from any programming
language. This allows integration of VisualPlus 3 into other applications, such as hydro
testing equipment software.   

Multiple instances of VisualPlus 3 software can be started to allow multiple VisualPlus 3
units connected to the same computer to run at the same time with different size probes
connected to each VisualPlus 3 unit.

Visual Basic examples provided in the following sections assume that a reference to VISPlus
object has been added to your project. Please run VisualPlus 3 application once to make
sure that the registry is set correctly to allow the reference to show up in the Project->Add
Reference option in Visual Basic. It will be under COM tab. Double-click on the VISPlus
component name to add it to the project.

Under Visual Basic 6 the creation of VisualPlus 3 object is slightly different, the object
should be declared as follows:

Dim WithEvents vp1a As VISPlus.VisualPlusInterface

The object should be created as follows:

Set vp1a = New VISPlus.VisualPlusInterface

In order to prevent error messages related to database access from VisualPlus 3 the
database access has to be set up through ODBC. Go to Control Panel->Performance and
Maintenance->Administrative Tools->Data Sources (ODBC). Click on System DSN tab and
click on Add on the right.
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Select Microsoft Access Driver (*.mdb) and click Finish.

Enter the data source name that you will remember later, such as 'vp'. Description field is
optional, you can enter something like 'Visual Plus Database'. Click on Select and then find
the visplus4.mdb file typically located in C:\Program Files\Visual Plus folder. If you do not
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have visplus4.mdb file in that folder please make sure that you run VisualPlus 3 application
at least once to create it. Select the visuplus4.mdb file and click OK.

Click OK two more times to close the ODBC Data source Administrator window. Run
VisualPlus 3 application and select Database->Settings. Click on the ODBC DSN radio
button and type in the name of the data source name that you defined in the previous step.
In this case you can type in 'vp'. Alternatively you can click on the Browse button and select
the appropriate database source name. Set other database settings as desired and click
OK. VisualPlus 3 application will terminate and after you run it again it will connect to the
database through ODBC driver allowing multiple instances of the application to talk to the
database without errors.

4.1 Creating, showing and closing VisualPlus

Create VisualPlus 3 instance as follows:

Dim WithEvents VP1a As VISPlus.VisualPlusInterface
' Create the object
VP1a = New VISPlus.VisualPlusInterfaceClass
' Set com port for this instance of the application, no need if only running one instance
' it will default to the com port specified in Preferences.
VP1a.SetComPort(Val(ComPort1.Text))
' Disable user's ability to close the application via Alt-F4/File->Exit/System Menu->Close/X
VP1a.AllowUserCloseApplication = False

at this point a VisualPlus 3 instance will be running and the main window is hidden.

To show the window  use ShowWindow() function, to hide the window again, use
HideWindow() function:

VP1a.ShowWindow()
VP1a.HideWindow()

To close the VisualPlus 3 instance call TerminateApplication() function as follows:

VP1a.TerminateApplication()
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In your handler of OnApplicationTerminated() event set the object to Nothing:

Private Sub VP1a_OnApplicationTerminated() Handles VP1a.OnApplicationTerminated
       VP1a = Nothing
    End Sub

4.2 Calibrating

Each VisualPlus 3 instance has to be calibrated at the beginning of the day and if there is a
loss of communication with VisualPlus 3 unit or the probe. Calibrate as follows:

Private Sub Calibrate1_Click(ByVal sender As System.Object, ByVal e As
System.EventArgs) Handles Calibrate1.Click

       Dim nCalibrationRecordID 

On Error GoTo ErrorHandler

        VP1a.ShowWindow()
        VP1a.Calibrate(Inspector1.Text, Val(ProbeType1.Text), nCalibrationRecordID)
        VP1a.HideWindow()
        Exit Sub

ErrorHandler:
        MsgBox(CStr(Err.Number) & " - " & Err.Description)

End Sub

at this point the VisualPlus 3 instance will be calibrated and ready for inspection. If a loss of
calibration occurs due to unplugged probe/loss of power to the unit or communication failure
an OnCalibrationLost event will be sent. You can handle it as follows:

Private Sub VP1a_OnCalibrationLost() Handles VP1a.OnCalibrationLost
        MsgBox("Unit 1 lost calibration.")
    End Sub

4.3 Inspecting

Inspection can be started by calling StartInspection method as follows:

    Private Sub Inspect1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Inspect1.Click
     On Error GoTo ErrorHandler
     Dim nResult As Integer
     Dim tMfg As Date
     tMfg = #5/31/1993#
     VP1a.ShowWindow()
     VP1a.StartInspection("B333", "Luxfer", "Etogen", "Alex Okun", tMfg, tMfg, tMfg)
     Exit Sub
    ErrorHandler:
     MsgBox("Unit 1 inspection failed to start.")
    End Sub

Please note that this function will return immediately even if acquisition has started. You can
poll InspectionResults property to find out if inspection is done. If the returned value is
VPA_INSPECTION_RUNNING then inspection is not complete. All other values indicate that
inspection was either aborted or it has been finished. Alternatively you can implement 
OnInspectionDone handler which is called when user saves the inspection file through the
main menu or by hitting F8:

    Private Sub VP1a_OnInspectionDone(ByVal nInspectionResult As Byte, ByVal lInspectionRecordID As Integer, ByVal sSavedFilePathName As String, ByVal lDatabaseFileRecordID As Integer) Handles VP1a.OnInspectionDone
     VP1a.HideWindow()
     MsgBox("Unit 1 inspection done.")
    End Sub



Visual Plus Automation Interface 107

(c) 2006-08, Saryna Technologies LLC/Advanced Inspection Technology

4.4 Reference

VisualPlus 3 Automation interface methods, properties, and constants are described in this
section.

4.4.1 Methods

SetComPort(LONG nComPort) - set the com port of this VisualPlus 3 instance. This call is
only necessary if multiple instances of VisualPlus 3 will be created. If only a single instance
is used then the com port can be specified in VisualPlus 3 application. Normally S_OK is
returned. A return value of E_FAIL is possible if there are major issues with the application.

ShowWindow() - show VisualPlus 3 window maximized, the splitter bars are also reset to
their original state. Normally S_OK is returned. A return value of E_FAIL is possible if there
are major issues with the application.

HideWindow() - hide VisualPlus 3 window, the application is still running in the background.
Normally S_OK is returned. A return value of E_FAIL is possible if there are major issues
with the application. 

TerminateApplication() - terminate VisualPlus 3 application. Don't forget to destroy the
interface to the application inOnApplicationTerminated event handler. In Visual Basic you
can just set the interface variable = Nothing. Normally S_OK is returned. A return value of
E_FAIL is possible if there are major issues with the application.

Calibrate(BSTR sInspectorName, LONG nProbeType, LONG* nCalibrationRecordID) -
calibrate this instance of VisualPlus 3 application.  The probe type will be preselected
according to nProbeType variable (see Constants section for values) and the inspector
name will be set to sInspectorName. If calibration was aborted or did not succeed then
E_ABORT error will be returned, otherwise S_OK is returned, nCalibrationRecordID is set to
the ID of the calibration record created in VisualPlus 3 database in CalibrationRecords . A
return value of E_FAIL is possible if there are major issues with the application. An
OnCalibrationLost event is sent if a previously calibrated unit looses it's calibration due to
unplugged probe/loss of power to the unit or communication failure.

StartInspection(BSTR sSerialNumber, BSTR sManufacturer, BSTR sCustomer, BSTR
sInspectorName, DATE tMfgDate, DATE tLastHydroDate, DATE tLastVisualPlusDate,
BSTR sDOTSpecExempt) - start inspection on this instance of VisualPlus 3 application.
The tank serial number, manufacturer, customer name, inspector name, tank manufacturing
date, tank last hydro date, tank last visual plus inspection date, and DOT Spec/Exemption
are passed on to the VisualPlus 3 application. The correct manufacturing date and
manufacturer must be supplied in order to properly classify the tank alloy type. The
manufacturer field is not case sensitive. Also, if DOT Spec/Exemption is a required
field, as set in Preferences dialog, then this field must not be empty. If inspection was
aborted or an error  occurred (missing fields like serial number, hardware errors, etc.) then
E_ABORT error will be returned, otherwise S_OK is returned. A return value of E_FAIL is
possible if there are major issues with the application. An OnInspectionDone event is sent
when inspection is completed. This happens when the user elects to save the file via the
main menu or by pressing F8. Alternatively the status can be polled using 
InspectionResults property.

GetInspectionDataInfo(LONG* nStartIndex, LONG* nEndIndex, LONG*
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nDataPointsPerTurn) - retrieve inspection raw data information. The amount of data
available is nEndIndex - nStartIndex + 1. This should be used to allocate an appropriate
array of Int32 type in VB.NET and Long in VB6 (Long type in VB.NET is 64bit and we need
32bit elements in the array). The nDataPointsPerTurn specifies the number of points in each
revolution, typically the VisualPlus 3 data has 0.25 degree resolution so there will be 360*4
points per revolution.

GetInspectionData(SAFEARRAY **psaArray, LONG nStartIndex, LONG nEndIndex) -
retrieve the raw data from the specified start index to the end index. The index variables
must be in the bounds of nStartIndex/nEndIndex retrieved with GetInspectionDataInfo. An
array with at least nEndIndex-nStartIndex+1 number of elements of type Int32 must be
passed to this function. If nStartIndex/nEndIndex is out of bounds or the array is too small
the function will return E_FAIL, otherwise the array is populated with data and S_OK is
returned.

GetCrackInfo(LONG nCrackIndex, LONG* nCrackPosition, LONG* nCrackAvgHeight,
LONG* nCrackAvgWidth, LONG* nFirstThread, LONG* nLastThread) - retrieve
information about a crack specified by zero-based nCrackIndex variable. The valid range for
nCrackIndex is: 0 <= nCrackIndex < NumberOfCracksDetected. This function returns
information on average crack angular position, average crack width, and the thread number
where crack begins and ends. This function will return E_FAIL if nCrackPosition is out of
bounds, otherwise S_OK is returned.

OpenFromFile(BSTR sPathName) - open VisualPlus 3 binary file from disk with the path
and name specified by sPathName. Returns S_OK if successfully loaded, E_ABORT if file
was not found and E_FAIL if other errors occurred.

OpenFromDatabase(LONG nInspectionRecordID) - open VisualPlus 3 binary file from
database with the record ID specified by nInspectionRecordID. This is the same value as 
lInspectionRecordID which is returned in OnInspectionDone event handler . Returns S_OK
if successfully loaded, E_ABORT if the record was not found or the file it references was not
found, E_FAIL in other cases.

SelectGraphView(LONG nGraphViewType) - Select the type of graph that will be
displayed in VisualPlus 3 window. This function is typically  called before calling
SaveGraphImage to select which view will be stored in the bitmap. See Constants section
for values accepted by this function under Graph View Types. Returns S_OK if everything
is normal and E_FAIL in other cases.

SaveGraphImage(BSTR sPathName, LONG nWidth, LONG nHeight, BSTR
sImageType, LONG nStyle) - Save a copy of the currently displayed graph in the specified
file. Set nWidth and nHeight to the needed resolution, image type should be one of "BMP",
"PNG", "JPEG", or "GIF". The nStyle specifies the style to apply to the bitmap. Currently the
only values are 0 (black background - not very good for printing) or 1 (white background -
preferred for printing).Returns S_OK if everything is normal, E_ABORT if could not open the
output file for writing and E_FAIL in other cases.

4.4.2 Properties

InspectionResults (get only) - get inspection status. Once inspection starts with
StartInspection the returned value will be VPA_INSPECTION_RUNNING if the inspection
is still being recorded/analyzed. The value will change to either
VPA_INSPECTION_UNKNOWN, VPA_INSPECTION_PASSED, or
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VPA_INSPECTION_FAILED once the user selects F8 to save the results of the inspection.
If inspection was aborted the return value will be VPA_INSPECTION_CANCELLED.

AllowUserCloseApplication (get/set) - enable/disable ability of user to close VisualPlus 3
application via Alt-F4/System Menu/etc. Set to False to disable those options. This can
prevent user from accidentally closing the application and loosing calibration.

NumberOfCracksDetected (get only) - returns the number of cracks that was detected
during analysis. Typically this value should be retrieved after inspection has been completed
(for example in the OnInspectionDone event handler). You can follow this call with calls to
GetCrackInfo to obtain information on each crack that was found.

Following properties are all get only properties, they are typically used after
loading a VisualPlus 3 file using OpenFromFile or OpenFromDatabase
methods:

InspectionSerialNumber - returns the cylinder serial number.

InspectionCustomer - returns the customer name.

InspectionDate - returns the date and time of the inspection.

InspectionDOTSpec - returns DOT spec, such as: 3AL, etc.

InspectionManufacturer - returns the cylinder manufacturer.

InspectionAlloy - returns the tank alloy type.

InspectionInspectedBy - returns the name of the person that performed the inspection.

InspectionMfgDate - returns manufacturing date of the cylinder.

InspectionLastHydroDate - returns last hydro test date of the cylinder.

InspectionLastVPDate - returns last VisualPlus inspection of the cylinder.

ProbeSerialNumber - return probe serial number.

ProbeType - returns probe type.

VisualPlusSerialNumber - returns VisualPlus 3 serial number.

CalibrationStandardSerialNumber - returns calibration standard serial number.

CalibrationStandardCrackInfo - returns information on calibration crack as a string.

4.4.3 Events

OnApplicationTerminated - called when VisualPlus 3 application instance is terminating.
Normally this occurs if TerminateApplication method is called or if user closes application.
To prevent user from closing the application set AllowUserCloseApplication property to
False.

OnCalibrationLost - called if a previously calibrated VisualPlus 3 unit looses it's calibration
due to unplugged probe/loss of power to the unit or communication failure. Normally you can
record this fact in the internal 'status' variable so that you can prompt the user to recalibrate
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this unit before allowing next inspection.

OnInspectionDone(ByVal nInspectionResult As Byte, ByVal lInspectionRecordID As
Integer, ByVal sSavedFilePathName As String, ByVal lDatabaseFileRecordID As
Integer) - called when inspection is completed. This happens when the user elects to save
current inspection file via the main menu or by pressing F8. The nInspectionResult will be
set to one of the possible VPA_INSPECTION_ constants. See InspectionResults property
for more info. lInspectionRecordID is the ID of the record in the database InspectionRecords
table. sSaveFilePathName is the full path and file name of the saved file (it will be blank if
file is saved directly into database). lDatabaseFileRecordID is the ID of the VisualPlus 3
binary file stored in the database. If the file was stored directly on disk then this variable will
be 0.

4.4.4 Constants

Return Values

 VPA_OK (0) - function call was successful.

 VPA_ERROR (1) - function call failed.

Return Values for VPGetInspectionResults

 VPA_INSPECTION_CANCELLED (0) - either inspection was never started or
it failed to start because some required field was missing or there was a
problem with hardware.

 VPA_INSPECTION_RUNNING (1) - inspection is currently running.

 VPA_INSPECTION_UNKNOWN (2) - inspection was completed but the
operator did not pass or fail the tank.

 VPA_INSPECTION_PASSED (3) - inspection was completed and the
operator passed the tank.

 VPA_INSPECTION_FAILED (4) - inspection was completed and the
operator/software failed the tank.

Probe Types

 VPA_PROBE_UNDEFINED             10000

 VPA_PROBE_SCUBA1                10001

 VPA_PROBE_SCBA2                 10002

 VPA_PROBE_SCBA3                 10003

 VPA_PROBE_SCBA4                 10004

 VPA_PROBE_M25                   10005

 VPA_PROBE_SPAREAIR              10006

 VPA_PROBE_25E                   10007

 VPA_PROBE_M18                   10008

 VPA_PROBE_6     10009

Graph View Types

 VIEW_TYPE_OVERLAY_THREADS       1

 VIEW_TYPE_INDUVIDUAL_THREADS 2

 VIEW_TYPE_LINEAR_GRAPH 3

 VIEW_TYPE_3D_SPIRAL 4

 VIEW_TYPE_LINEAR_SINGLE_ROW 5
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5 OpticalPlus Manual

5.1 Inspection

Turn on the light by turning light switch
clock-wise to maximum intensity. Insert
OpticalPlus into a cylinder allowing the
step ring to rest on the cylinder neck
shoulder. Loosen the step ring set screw
and lower OpticalPlus to the start of the
thread while observing through the
eyepiece. Tighten the step ring set screw.
Adjust focus by loosening focus set screw
and rotating the eyepiece. Tighten the set
screw when thread is in focus. Examine
the lower set of threads by rotating
OpticalPlus 360 degrees. Loosen step ring
set screw, raise OpticalPlus to view the
next set of threads. Repeat previous two
steps until all threads have been
examined. Don’t forget to turn off the light
after inspection.

Using with VisualPlus III

When used in combination with VisualPlus
III, OpticalPlus can be used to locate and
examine imperfections found during eddy
current testing. Make sure that you
perform VisualPlus inspection with probe
pointed at the first letter of cylinder serial
number when starting data acquisition.
Loosen step ring set screw, locate a tick
mark on the step ring scale corresponding
to the crack position angle reported by
VisualPlus. Line up this mark with the first
letter of the cylinder serial number. While
holding the ring in place with one hand,
line up a vertical grove on the side of
OpticalPlus with 0 scale mark on the step
ring and lower OpticalPlus in the cylinder
while examining threads.

5.2 Condeming Cylinders

While using OpticalPlus, if you find a feature that appears to be a crack, perform a follow-up
inspection with VisualPlus III to determine if what you are seeing is actually a crack. Look at
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the recorded trace in the location where you identified a potential crack. Note if there is a
peak at that location that was not identified because it is a superficial cut or if it is a valid
crack that is obscured by thread damage or corrosion. Do not condemn a cylinder for a
"crack" based solely on the use of OpticalPlus. Many common, harmless features found in
cylinder threads-for example, tooling stops, the attenuated tips of acceptable folds, and
superficial cuts or gouges-can be mistaken for cracks, especially under magnification. (This
restriction does not apply to threads that are badly corroded or otherwise damaged to such
an extent that a VisualPlus probe cannot be screwed in; such cylinders should be
condemned for reasons other than neck cracks.) Please use data from both OpticalPlus and
VisualPlus III instruments to make decisions in borderline cases.

5.3 Changing Batteries

OpticalPlus uses three N size alkaline batteries. While not as common as AA batteries the N
size battery can be obtained from Radio Shack, AIT, and most electronics stores.

Please play the battery change video on our website. Open www.visualplus.net, select
products and click on Battery Change Video in the Optical Plus section. 

To change batteries unscrew and remove eyepiece tube, unscrew and remove three cover
screw, carefully lift the cover and remove battery holders by gently pulling on wires or using
a screwdriver. Please note the wire arrangement so that OpticalPlus can be re-assembled in
the same order. Replace batteries noting the polarity indicated inside each battery holder.
Place both battery holders back into the instrument body in the same orientation as noted
during disassembly. Push wires with rubber tubes on them into channels to keep wires from
coming loose while placing the cover on OpticalPlus. Replace cover and tighten three cover
screws. Thread the eyepiece tube back into the instrument body.OpticalPlus uses three N
size alkaline batteries. While not as common as AA batteries the N size battery can be
obtained from Radio Shack, AIT, and most electronics stores. To change batteries unscrew
and remove eyepiece tube, unscrew and remove three cover screw, carefully lift the cover
and remove battery holders using pliers or a screwdriver. DO NOT PULL ON THE WIRES.
DO NOT BEND WIRES AT SOLDER JOINTS. THE WIRES ARE EASY TO BREAK. Please
note the wire arrangement so that OpticalPlus can be re-assembled in the same order.
Replace batteries noting the polarity indicated inside each battery holder. Place both battery
holders back into the instrument body in the same orientation as noted during disassembly.
Push wires with rubber tubes on them into channels to keep wires from coming loose while
placing the cover on OpticalPlus. Replace cover and tighten three cover screws. Thread the
eyepiece tube back into the instrument body.

If you break wires and would like to attempt to repair them yourself or if you are unsure on
how to put the battery holders back into the instrument body please see a document labelled
Wire Repair Instructions in the Products section of our website in the Optical Plus section. If
you do not feel comfortable attempting to repair the wires please send the OpticalPlus in for
service.

5.4 Maintenance

OpticalPlus uses acrylic lenses and first surface mirror. Please don’t use any solvents on
those surfaces. Cleaning is best done with clean compressed air. Dust accumulation should
not affect image quality while performing an inspection, even though it might be visible if
OpticalPlus is not focused on a surface.
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